summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene Lamskoy2021-12-18 23:15:24 +0200
committerEugene Lamskoy2021-12-18 23:15:24 +0200
commitd81998d8651117bff52683e4b1ad38fc7e4434f3 (patch)
treeba7fdedb0ce30a493dd51456ad8fcc43b2b459ec
parent26d02bafd42feba872735a211f2419ec2b865c6a (diff)
downloadaur-d81998d8651117bff52683e4b1ad38fc7e4434f3.tar.gz
Proper build without any dependencies
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD88
-rw-r--r--golded7
-rw-r--r--ncurses.patch38
4 files changed, 94 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa224596820c..0eba0b59d199 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = golded-plus-git
pkgdesc = golded-plus Fidonet Mail Reader/Editor
pkgver = r1548.9b28fa8
- pkgrel = 2
+ pkgrel = 4
url = http://bbconf.sourceforge.net/
arch = i686
arch = x86_64
@@ -12,17 +12,19 @@ pkgbase = golded-plus-git
makedepends = glibc
makedepends = groff
makedepends = patchelf
- depends = screen
depends = luit
- depends = ncurses-nonwide
provides = golded-plus
source = golded-plus-git::git+https://github.com/golded-plus/golded-plus.git
+ source = https://ftp.gnu.org/pub/gnu/ncurses/ncurses-6.2.tar.gz
source = ncurses.patch
source = addline.patch
source = widescreen.patch
+ source = golded
md5sums = SKIP
- md5sums = 101d41109a4d32a562142971de846219
+ md5sums = e812da327b1c2214ac1aed440ea3ae8d
+ md5sums = ab59c44a926a1d5f699cc6fe9bea87b2
md5sums = 5af9e7339bcfa4eb12736599b6ee266a
md5sums = 5c05574fdfa982acfefc1ca45f830d05
+ md5sums = 46c9bbd1d4aacda4f8f0874ee15d298b
pkgname = golded-plus-git
diff --git a/PKGBUILD b/PKGBUILD
index 417e887d5c89..047da48fdb95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,52 @@
pkgname=golded-plus-git
pkgver=r1548.9b28fa8
-pkgrel=2
+_ncurses_pkgver=6.2
+_ncurses="ncurses"
+pkgrel=4
pkgdesc="golded-plus Fidonet Mail Reader/Editor"
arch=('i686' 'x86_64')
url="http://bbconf.sourceforge.net/"
license=('GPL2')
-source=("${pkgname}::git+https://github.com/golded-plus/golded-plus.git"
- "ncurses.patch" "addline.patch" "widescreen.patch")
+source=(
+ "${pkgname}::git+https://github.com/golded-plus/golded-plus.git"
+ "https://ftp.gnu.org/pub/gnu/ncurses/${_ncurses}-${_ncurses_pkgver}.tar.gz"
+ "ncurses.patch" "addline.patch" "widescreen.patch" "golded"
+)
makedepends=('git' 'gcc' 'make' 'glibc' 'groff' 'patchelf')
-depends=('screen' 'luit' 'ncurses-nonwide')
+depends=('luit')
provides=('golded-plus')
build() {
- cd "${pkgname}"
- make USE_NCURSES=1 KOI8=1 WIDE_NCURSES=0
+ rm -rf ncurses
+ mkdir ncurses
+ pushd "${_ncurses}-${_ncurses_pkgver}"
+ ./configure --prefix=/usr/lib/ncurses-golded \
+ --mandir=/usr/lib/golded-ncurses/usr/share/man \
+ --with-pkg-config-libdir=/usr/lib/ncurses-golded/usr/lib/pkgconfig \
+ --with-shared --with-normal --without-debug --without-ada \
+ --disable-widec --enable-pc-files --with-cxx-binding --with-cxx-shared \
+ --without-manpages --without-tests --without-pkg-config \
+ --with-static --with-cxx-static --with-abi-version=5
+ make clean
+ make -j8
+ make DESTDIR="${srcdir}/ncurses" install
+ popd
+ pushd "${pkgname}"
+ make WIDE_NCURSES=0 USE_NCURSES=1 KOI8=1
pushd docs
make tokentpl.txt
make tokencfg.txt
popd
make docs
+ popd
}
prepare() {
- cp "${pkgname}/golded3/mygolded.__h" "${pkgname}/golded3/mygolded.h"
cd "${pkgname}"
- patch -p1 -i "${srcdir}/ncurses.patch"
- patch -p1 -i "${srcdir}/addline.patch"
- patch -p1 -i "${srcdir}/widescreen.patch"
-
+ cp "golded3/mygolded.__h" "golded3/mygolded.h"
+ patch -p1 -i "../ncurses.patch"
+ patch -p1 -i "../addline.patch"
+ patch -p1 -i "../widescreen.patch"
iconv -c -f cp866 -t utf8 docs/rusfaq.txt | sed 2s/cp866/utf-8/ >docs/rusfaq.utf8
iconv -c -f cp866 -t utf8 docs/notework.rus | sed 2s/cp866/utf-8/ >docs/notework_rus.utf8
iconv -c -f cp866 -t koi8-r docs/rusfaq.txt | sed 2s/cp866/koi8/ >docs/rusfaq.koi8
@@ -52,28 +71,33 @@ pkgver() {
}
package() {
- cd "$pkgname"
- mkdir -m 755 -p ${pkgdir}/usr/share/goldedplus/{docs,charset,colorset,config,template}
- install -d ${pkgdir}/usr/bin
- install bin/*lnx bin/golded ${pkgdir}/usr/bin/
- patchelf --set-rpath /opt/ncurses-nonwide/lib ${pkgdir}/usr/bin/gedlnx
- chmod 755 ${pkgdir}/usr/bin/gedlnx
- install -d ${pkgdir}/usr/man/man1
- install -m 644 docs/*.1 ${pkgdir}/usr/man/man1/
- install -m 644 ${pkgdir}/usr/man/man1/golded.1 ${pkgdir}/usr/man/man1/gedlnx.1
- install -m 644 ${pkgdir}/usr/man/man1/goldnode.1 ${pkgdir}/usr/man/man1/gnlnx.1
- install -m 644 ${pkgdir}/usr/man/man1/rddt.1 ${pkgdir}/usr/man/man1/rddtlnx.1
- install -m 644 etc/gecolor.conf ${pkgdir}/usr/share/goldedplus/colorset/gedcolor.cfg
- install -m 644 cfgs/config/* ${pkgdir}/usr/share/goldedplus/config
- install -m 644 cfgs/template/* ${pkgdir}/usr/share/goldedplus/template
- install -m 644 cfgs/charset/* ${pkgdir}/usr/share/goldedplus/charset
- install -m 644 cfgs/colorset/* ${pkgdir}/usr/share/goldedplus/colorset
- install -m 644 docs/*.utf8 ${pkgdir}/usr/share/goldedplus/docs
- install -m 644 docs/*.koi8 ${pkgdir}/usr/share/goldedplus/docs
- install -m 644 docs/{tips,linux,notework,tokencfg,tokentpl}.txt ${pkgdir}/usr/share/goldedplus/docs
+ pushd "${_ncurses}-${_ncurses_pkgver}"
+ make DESTDIR="${pkgdir}" install
+ popd
+
+ pushd "${pkgname}"
+ mkdir -m 755 -p "${pkgdir}/usr/share/goldedplus"/{docs,charset,colorset,config,template}
+ install -d "${pkgdir}/usr/bin"
+ install -m 755 bin/rddtlnx "${pkgdir}/usr/bin/rddt"
+ install -m 755 bin/gnlnx "${pkgdir}/usr/bin/goldnode"
+ install -m 755 bin/gedlnx "${pkgdir}/usr/bin/gedlnx"
+ install -m 755 ../golded "${pkgdir}/usr/bin/golded"
+ patchelf --set-rpath /usr/lib/ncurses-golded/lib "${pkgdir}/usr/bin/gedlnx"
+ install -d "${pkgdir}/usr/man/man1"
+ install -m 644 docs/*.1 "${pkgdir}/usr/man/man1/"
+ install -m 644 etc/gecolor.conf "${pkgdir}/usr/share/goldedplus/colorset/gedcolor.cfg"
+ install -m 644 cfgs/config/* "${pkgdir}/usr/share/goldedplus/config"
+ install -m 644 cfgs/template/* "${pkgdir}/usr/share/goldedplus/template"
+ install -m 644 cfgs/charset/* "${pkgdir}/usr/share/goldedplus/charset"
+ install -m 644 cfgs/colorset/* "${pkgdir}/usr/share/goldedplus/colorset"
+ install -m 644 docs/*.utf8 "${pkgdir}/usr/share/goldedplus/docs"
+ install -m 644 docs/*.koi8 "${pkgdir}/usr/share/goldedplus/docs"
+ install -m 644 docs/{tips,linux,notework,tokencfg,tokentpl}.txt "${pkgdir}/usr/share/goldedplus/docs"
}
md5sums=('SKIP'
- '101d41109a4d32a562142971de846219'
+ 'e812da327b1c2214ac1aed440ea3ae8d'
+ 'ab59c44a926a1d5f699cc6fe9bea87b2'
'5af9e7339bcfa4eb12736599b6ee266a'
- '5c05574fdfa982acfefc1ca45f830d05')
+ '5c05574fdfa982acfefc1ca45f830d05'
+ '46c9bbd1d4aacda4f8f0874ee15d298b')
diff --git a/golded b/golded
new file mode 100644
index 000000000000..5dd4dacff39f
--- /dev/null
+++ b/golded
@@ -0,0 +1,7 @@
+#!/bin/bash
+GEDLNX=$(which gedlnx)
+if [ ! -x $GEDLNX ]; then
+ echo gedlnx is not avaiabled, sorry
+ exit 1
+fi
+exec /usr/bin/luit -x -encoding koi8-r -- "$GEDLNX" $*
diff --git a/ncurses.patch b/ncurses.patch
index cb395c80b764..a48894afecd4 100644
--- a/ncurses.patch
+++ b/ncurses.patch
@@ -1,21 +1,33 @@
--- 1/GNUmakef.def
+++ 2/GNUmakef.def
-@@ -116,7 +116,7 @@
+@@ -159,10 +159,11 @@
+ LIBEXT=.a
+ CFLAGS+=-DHAVE_SNPRINTF -DHAVE_VSNPRINTF -DHAVE_STDARG_H
ifeq ($(WIDE_NCURSES),1)
- LIBCURSES=-L/opt/csw/lib -lncursesw
- else
--LIBCURSES=-L/opt/csw/lib -lncurses
-+LIBCURSES=-L/opt/ncurses-nonwide/lib -lncurses
- endif
- else
- ifeq ($(PLATFORM),osx) # Mac OSX
-@@ -154,7 +154,8 @@
- CFLAGS+=-I/usr/include/ncursesw/
- LIBCURSES=-lncursesw
+-CFLAGS+=-I/usr/include/ncursesw/
+-LIBCURSES=-lncursesw
++LIBCURSES=-L../../ncurses/usr/lib/ncurses-golded/lib -lncursesw
++CFLAGS+=-I../../ncurses/usr/lib/ncurses-golded/include
else
-LIBCURSES=-lncurses
-+CFLAGS+=-D_GNU_SOURCE -D_DEFAULT_SOURCE -I/opt/ncurses-nonwide/include
-+LIBCURSES=-L/opt/ncurses-nonwide/lib -lncurses
++LIBCURSES=-L../../ncurses/usr/lib/ncurses-golded/lib -lncurses
++CFLAGS+=-I../../ncurses/usr/lib/ncurses-golded/include
endif
endif
endif
+--- 1/GNUmakef.prg 2021-12-18 20:20:18.934724854 +0200
++++ 2/GNUmakef.prg 2021-12-18 20:20:24.094724915 +0200
+@@ -13,9 +13,10 @@
+ FGLIBS=$(addprefix $(FLIBPATH)/lib, $(addsuffix $(LIBEXT), $(GLIBS)))
+
+ $(TOP)/$(BIN)/$(SHORTTARGET)$(PLATFORM)$(EXEEXT): $(OBJS) $(FGLIBS) $(ADDS)
+- @echo -n Linking $(TARGET)...
+- @$(CXX) $(LNKFLAGS) -o $@ $(FOBJPATH)/*$(OBJEXT) $(ADDS) $(LIBS) -L$(FLIBPATH)
+- @echo done
++ echo -n Linking $(TARGET)...
++ pwd
++ $(CXX) $(LNKFLAGS) -o $@ $(FOBJPATH)/*$(OBJEXT) $(ADDS) $(LIBS) -L$(FLIBPATH)
++ echo done
+
+ $(FGLIBS): $(GLIBS)
+