summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwxqwinner2023-10-25 17:05:17 +0800
committerwxqwinner2023-10-25 17:05:17 +0800
commit0f107a1edceb59766ff74993ffe4c51313c7d7f8 (patch)
tree2eafc486c2c928ae22b1e3ed72b6a69286d57817
downloadaur-0f107a1edceb59766ff74993ffe4c51313c7d7f8.tar.gz
file(goldendict): first commit
-rw-r--r--PKGBUILD46
-rw-r--r--goldendict-ng.desktop9
-rw-r--r--goldendict-ng.pngbin0 -> 22251 bytes
3 files changed, 55 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d1b96abfd34f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: wxqwinner <wxqwinner@gmail.com>
+pkgname=goldendict-ng-appimage
+_appimage=6.5.2-GoldenDict-ng-x86_64.AppImage
+pkgver=23.09.29
+_pkgver=23.09.29-MoonCake.7f0f8778
+pkgrel=0
+pkgdesc="Feature-rich dictionary lookup program supporting multiple dictionary formats."
+arch=('x86_64')
+url="https://github.com/xiaoyifang/goldendict-ng"
+license=('GPL3')
+options=('!strip')
+conflicts=(
+ 'goldendict-ng'
+ 'goldendict-ng-git'
+)
+
+source=("${_appimage}::https://github.com/xiaoyifang/goldendict-ng/releases/download/v${_pkgver}/${_appimage}"
+ "goldendict-ng.desktop"
+ "goldendict-ng.png"
+ )
+
+sha256sums=(
+ '43c024c1f30b5a1c7ee5325e0fabb5a1ebc3a8af16494d41d51920e68f9c0efa'
+ '00edc466969eaa435ce75acb4a1075189f47ca210aee9ec0251583c5a1fce343'
+ '935ccc5467aa896e6fc2061c059ef2b79fb791213fda76e508bb6b539af23bec'
+ )
+
+prepare() {
+ chmod +x "${_appimage}"
+}
+
+package() {
+
+ # Install
+ install -Dm755 "${srcdir}/${_appimage}" "${pkgdir}/opt/appimages/GoldenDict-ng.AppImage"
+
+ # Install Desktop file
+ install -Dm644 "${srcdir}/goldendict-ng.desktop" "${pkgdir}/usr/share/applications/goldendict-ng.desktop"
+
+ # Install Icon images
+ install -Dm644 "${srcdir}/goldendict-ng.png" "${pkgdir}/usr/share/pixmaps/goldendict-ng.png"
+
+ # Symlink executable
+ install -dm755 "${pkgdir}/usr/bin"
+ ln -sf "/opt/appimages/GoldenDict-ng.AppImage" "${pkgdir}/usr/bin/goldendict-ng"
+}
diff --git a/goldendict-ng.desktop b/goldendict-ng.desktop
new file mode 100644
index 000000000000..fae2f583b17a
--- /dev/null
+++ b/goldendict-ng.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Terminal=false
+Categories=Office;Dictionary;Education;Qt;
+Name=GoldenDict-ng
+GenericName=Multiformat Dictionary
+Comment=A feature-rich dictionary lookup program
+Icon=goldendict-ng
+Exec=goldendict-ng
diff --git a/goldendict-ng.png b/goldendict-ng.png
new file mode 100644
index 000000000000..3baa9abd513f
--- /dev/null
+++ b/goldendict-ng.png
Binary files differ