summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVirtualTam2015-08-18 00:13:29 +0200
committerVirtualTam2015-08-18 00:13:29 +0200
commit90c59c5264d97cc757f45f4b61da219a19d9af73 (patch)
tree4ede8aa7879dba9497fcc99168d846dfae6c2bfe
parent0fcd54f6e10550feead3ac521481d32964d61fe2 (diff)
downloadaur-90c59c5264d97cc757f45f4b61da219a19d9af73.tar.gz
qt4x5: update PKGBUILD to support the Qt5 branch
Signed-off-by: VirtualTam <virtualtam@flibidi.net>
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bc20674f53eb..9aab75f4399c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = goldendict-git
+pkgbase = goldendict-qt5-git
pkgdesc = Feature-rich dictionary lookup program.
- pkgver = 1.5.0.RC.489.gb4bb1e9
+ pkgver = 1.5.0.RC.550.g1df1b3d
pkgrel = 1
url = http://goldendict.org/
arch = i686
@@ -14,8 +14,8 @@ pkgbase = goldendict-git
depends = libvorbis
depends = libxtst
depends = lzo2
- depends = qt4
- depends = qtwebkit
+ depends = qt5-base
+ depends = qt5-webkit
depends = zlib
provides = goldendict
conflicts = goldendict
@@ -24,8 +24,8 @@ pkgbase = goldendict-git
replaces = goldendict
replaces = goldendict-svn
replaces = goldendict-git-opt
- source = git://github.com/goldendict/goldendict.git
+ source = git://github.com/goldendict/goldendict.git#branch=qt4x5
sha256sums = SKIP
-pkgname = goldendict-git
+pkgname = goldendict-qt5-git
diff --git a/PKGBUILD b/PKGBUILD
index 4c28f41243b1..0ad4dfe497dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: VirtualTam <virtualtam@flibidi.net>
# Contributor: Eugene Yudin aka Infy <Eugene dot Yudin at gmail dot com>
-pkgname=goldendict-git
-pkgver=1.5.0.RC.489.gb4bb1e9
+pkgname=goldendict-qt5-git
+pkgver=1.5.0.RC.550.g1df1b3d
pkgrel=1
pkgdesc="Feature-rich dictionary lookup program."
arch=('i686' 'x86_64')
url="http://goldendict.org/"
license=('GPL3')
-depends=('ffmpeg' 'hunspell' 'libao' 'libeb' 'libvorbis' 'libxtst' 'lzo2' 'qt4' 'qtwebkit' 'zlib')
+depends=('ffmpeg' 'hunspell' 'libao' 'libeb' 'libvorbis' 'libxtst' 'lzo2' 'qt5-base' 'qt5-webkit' 'zlib')
makedepends=('git')
conflicts=('goldendict' 'goldendict-svn' 'goldendict-git-opt')
provides=('goldendict')
replaces=('goldendict' 'goldendict-svn' 'goldendict-git-opt')
_gitname="goldendict"
-source=(git://github.com/goldendict/goldendict.git)
+source=(git://github.com/goldendict/goldendict.git#branch=qt4x5)
sha256sums=(SKIP)
pkgver() {
@@ -30,7 +30,7 @@ prepare() {
build(){
cd ${_gitname}
- PREFIX="/usr" qmake-qt4
+ PREFIX="/usr" qmake-qt5
make
}