summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2019-01-05 19:31:34 +0330
committerMohammadreza Abdollahzadeh2019-01-05 19:31:34 +0330
commitaccd6fb4422fad13c5347c0050c368ec4d42d6c6 (patch)
tree1980a92fd8f7d428dd8de5c5d5f369f1931ae0e6
parent23450109db974edd69e8028c43010a8808062644 (diff)
downloadaur-accd6fb4422fad13c5347c0050c368ec4d42d6c6.tar.gz
add qt5-multimedia as dependency, change source URL, add zim_support as compile flag to add support for Zim file type
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96e96f5b3ded..7a0f66022883 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sun Mar 19 20:04:12 UTC 2017
pkgbase = goldendict-qt5-git
pkgdesc = Feature-rich dictionary lookup program.
- pkgver = 1.5.0.RC2.76.gadb1bf5
+ pkgver = 1.5.0.RC2.338.g6d46fd15
pkgrel = 1
url = http://goldendict.org/
arch = i686
@@ -13,6 +11,7 @@ pkgbase = goldendict-qt5-git
depends = hunspell
depends = libao
depends = libeb
+ depends = qt5-multimedia
depends = qt5-svg
depends = qt5-tools
depends = qt5-webkit
@@ -24,7 +23,7 @@ pkgbase = goldendict-qt5-git
replaces = goldendict
replaces = goldendict-svn
replaces = goldendict-git-opt
- source = git://github.com/goldendict/goldendict.git
+ source = git+https://github.com/goldendict/goldendict.git
sha256sums = SKIP
pkgname = goldendict-qt5-git
diff --git a/PKGBUILD b/PKGBUILD
index 25b639c42e07..36c8bf37cbc2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,22 @@
-# Maintainer: VirtualTam <virtualtam@flibidi.net>
+# $Id$
+# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+# Contributor: VirtualTam <virtualtam@flibidi.net>
# Contributor: Eugene Yudin aka Infy <Eugene dot Yudin at gmail dot com>
+
pkgname=goldendict-qt5-git
-pkgver=1.5.0.RC2.76.gadb1bf5
+pkgver=1.5.0.RC2.338.g6d46fd15
pkgrel=1
pkgdesc="Feature-rich dictionary lookup program."
arch=('i686' 'x86_64')
url="http://goldendict.org/"
license=('GPL3')
-depends=('ffmpeg' 'hunspell' 'libao' 'libeb'
- 'qt5-svg' 'qt5-tools' 'qt5-webkit' 'qt5-x11extras')
+depends=('ffmpeg' 'hunspell' 'libao' 'libeb' 'qt5-multimedia' 'qt5-svg' 'qt5-tools' 'qt5-webkit' 'qt5-x11extras')
makedepends=('git')
conflicts=('goldendict' 'goldendict-svn' 'goldendict-git-opt')
provides=('goldendict')
replaces=('goldendict' 'goldendict-svn' 'goldendict-git-opt')
_gitname="goldendict"
-source=(git://github.com/goldendict/goldendict.git)
+source=("git+https://github.com/goldendict/goldendict.git")
sha256sums=(SKIP)
pkgver() {
@@ -24,14 +26,13 @@ pkgver() {
prepare() {
cd ${_gitname}
- msg "Fixing flags"
echo "QMAKE_CXXFLAGS_RELEASE = $CFLAGS" >> goldendict.pro
echo "QMAKE_CFLAGS_RELEASE = $CXXFLAGS" >> goldendict.pro
}
build(){
cd ${_gitname}
- PREFIX="/usr" qmake-qt5
+ PREFIX="/usr" qmake-qt5 "CONFIG+=zim_support"
make
}
@@ -39,3 +40,4 @@ package() {
cd ${_gitname}
make INSTALL_ROOT="${pkgdir}" install
}
+# vim:set ts=2 sw=2 et: