summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVirtualTam2015-07-13 03:07:42 +0200
committerVirtualTam2015-07-13 03:07:42 +0200
commitb3e5b87b55c64cbe543667c299aa17c0f044b4a4 (patch)
treebe5a7502d60085a03106735a11f95631f5300377
downloadaur-b3e5b87b55c64cbe543667c299aa17c0f044b4a4.tar.gz
Initial import of goldendict-git
Signed-off-by: VirtualTam <virtualtam@flibidi.net>
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD40
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6fd01ce72d21
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = goldendict-git
+ pkgdesc = Feature-rich dictionary lookup program.
+ pkgver = 1.5.0.RC.487.g043a10c
+ pkgrel = 1
+ url = http://goldendict.org/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = ffmpeg
+ depends = hunspell
+ depends = libao
+ depends = libeb
+ depends = libvorbis
+ depends = libxtst
+ depends = lzo2
+ depends = qt4
+ depends = qtwebkit
+ depends = zlib
+ provides = goldendict
+ conflicts = goldendict
+ conflicts = goldendict-svn
+ conflicts = goldendict-git-opt
+ replaces = goldendict
+ replaces = goldendict-svn
+ replaces = goldendict-git-opt
+ source = git://github.com/goldendict/goldendict.git
+ sha256sums = SKIP
+
+pkgname = goldendict-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef1fe83e4d85
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: VirtualTam <virtualtam@flibidi.net>
+# Contributor: Eugene Yudin aka Infy <Eugene dot Yudin at gmail dot com>
+pkgname=goldendict-git
+pkgver=1.5.0.RC.487.g043a10c
+pkgrel=1
+pkgdesc="Feature-rich dictionary lookup program."
+arch=('i686' 'x86_64')
+url="http://goldendict.org/"
+license=('GPL3')
+depends=('ffmpeg' 'hunspell' 'libao' 'libeb' 'libvorbis' 'libxtst' 'lzo2' 'qt4' 'qtwebkit' 'zlib')
+makedepends=('git')
+conflicts=('goldendict' 'goldendict-svn' 'goldendict-git-opt')
+provides=('goldendict')
+replaces=('goldendict' 'goldendict-svn' 'goldendict-git-opt')
+_gitname="goldendict"
+source=(git://github.com/goldendict/goldendict.git)
+sha256sums=(SKIP)
+
+pkgver() {
+ cd ${_gitname}
+ git describe --always | sed 's|-|.|g'
+}
+
+prepare() {
+ cd ${_gitname}
+ msg "Fixing flags"
+ echo "QMAKE_CXXFLAGS_RELEASE = $CFLAGS" >> goldendict.pro
+ echo "QMAKE_CFLAGS_RELEASE = $CXXFLAGS" >> goldendict.pro
+}
+
+build(){
+ cd ${_gitname}
+ PREFIX="/usr" qmake-qt4
+ make
+}
+
+package() {
+ cd ${_gitname}
+ make INSTALL_ROOT="${pkgdir}" install
+}