summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCédric Connes2019-07-07 13:45:49 +0200
committerCédric Connes2019-07-07 13:45:49 +0200
commit74efaac73ddd5f9613162471a012a33ae643aef7 (patch)
treea879630fc30847bc131e75a8b3041a6a021a9c06
downloadaur-74efaac73ddd5f9613162471a012a33ae643aef7.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..940341930e97
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = goldtree-py
+ pkgdesc = A python port of XorTroll's Goldtree
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = https://github.com/friedkeenan/GoldtreePy
+ arch = any
+ license = GPL3
+ depends = python
+ depends = python-pyusb
+ source = https://github.com/friedkeenan/GoldtreePy/archive/v0.5.tar.gz
+ sha256sums = de22ead073629662f22333dbfcb904227cd051986e5f38f49275e3311a4ebf1f
+
+pkgname = goldtree-py
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..10f7f3923ba6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Cédric Connes <cedric.connes@gmail.com>
+
+pkgname=goldtree-py
+_githubver=0.5
+pkgver="$_githubver.0"
+pkgrel=1
+pkgdesc="A python port of XorTroll's Goldtree"
+arch=('any')
+url='https://github.com/friedkeenan/GoldtreePy'
+license=('GPL3')
+depends=('python'
+ 'python-pyusb')
+source=("https://github.com/friedkeenan/GoldtreePy/archive/v$_githubver.tar.gz")
+sha256sums=('de22ead073629662f22333dbfcb904227cd051986e5f38f49275e3311a4ebf1f')
+
+package() {
+ cd "GoldtreePy-$_githubver"
+ install -t "$pkgdir/usr/lib/$pkgname" -Dm644 PFS0.py
+ install -t "$pkgdir/usr/lib/$pkgname" -Dm755 Goldtree.py
+ install -t "$pkgdir/usr/share/licenses/$pkgname" -Dm644 LICENSE
+ install -d "$pkgdir/usr/bin"
+ ln -s "/usr/lib/$pkgname/Goldtree.py" "$pkgdir/usr/bin/$pkgname"
+}