summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorquexten2024-05-04 04:12:13 +0000
committerquexten2024-05-04 04:12:13 +0000
commitc98b2b7109c5adc3c02f0d440fdc1b3df22a324c (patch)
tree6711174492dcd6e04422418d29e6b77b4cecd4aa
parent9b3a9869d100fa5363c84e562551ef1dff9bfe0a (diff)
downloadaur-c98b2b7109c5adc3c02f0d440fdc1b3df22a324c.tar.gz
Update AUR package from GitHub Actions automation
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec1da9f9e20e..1bc0476f6414 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = goldwarden
pkgdesc = A feature-packed Bitwarden compatible desktop integration
- pkgver = 0.2.16
+ pkgver = 0.3.1
pkgrel = 1
url = https://github.com/quexten/goldwarden
arch = x86_64
@@ -10,7 +10,7 @@ pkgbase = goldwarden
makedepends = gcc
makedepends = base-devel
depends = libfido2
- source = https://github.com/quexten/goldwarden/archive/refs/tags/v0.2.16.tar.gz
- sha256sums = a86e85e9cbd37181c412ca9e98e192551847da9ace456df09a0a3892164efa13
+ source = https://github.com/quexten/goldwarden/archive/refs/tags/v0.3.1.tar.gz
+ sha256sums = e809e774b6ae2ad94defceced1edaf2c05661911f2cc712865a9f5002c03ffe3
pkgname = goldwarden
diff --git a/PKGBUILD b/PKGBUILD
index 5b006619aa75..7da81e803153 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=goldwarden
-pkgver=0.2.16
+pkgver=0.3.1
pkgrel=1
pkgdesc='A feature-packed Bitwarden compatible desktop integration'
arch=('x86_64' 'aarch64')
@@ -8,7 +8,7 @@ license=('MIT')
depends=('libfido2')
makedepends=('go' 'gcc' 'base-devel')
source=("$url/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('a86e85e9cbd37181c412ca9e98e192551847da9ace456df09a0a3892164efa13')
+sha256sums=('e809e774b6ae2ad94defceced1edaf2c05661911f2cc712865a9f5002c03ffe3')
prepare(){
cd "$pkgname-$pkgver"
@@ -24,6 +24,8 @@ build() {
export GOFLAGS="-buildmode=pie -trimpath -modcacherw"
export CGO_ENABLED=1
+ echo "$pkgver" > cmd/version.txt
+
go mod tidy
go build -o build/$pkgname .
}
@@ -31,6 +33,6 @@ build() {
package() {
cd "$pkgname-$pkgver"
install -Dm755 build/$pkgname "$pkgdir"/usr/bin/$pkgname
- install -Dm644 "$srcdir/$pkgname-$pkgver/resources/com.quexten.goldwarden.policy" "$pkgdir/usr/share/polkit-1/actions/com.quexten.goldwarden.policy"
+ install -Dm644 "$srcdir/$pkgname-$pkgver/cli/resources/com.quexten.goldwarden.policy" "$pkgdir/usr/share/polkit-1/actions/com.quexten.goldwarden.policy"
chown root:root "$pkgdir/usr/share/polkit-1/actions/com.quexten.goldwarden.policy"
}