aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJP-Ellis2017-03-15 18:13:09 +1100
committerJP-Ellis2017-03-15 18:15:05 +1100
commit6ab00a2db3447ef00d1a8a2f529fdb0c2a102bcc (patch)
treeb73ac751e937e4b0617ce274e037354bdff7c81c
downloadaur-6ab00a2db3447ef00d1a8a2f529fdb0c2a102bcc.tar.gz
Initial commit
Signed-off-by: JP-Ellis <josh@jpellis.me>
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD33
-rw-r--r--README.md36
4 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b0464e639134
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Wed Mar 15 07:14:59 UTC 2017
+pkgbase = golem95
+ pkgdesc = A package for the numerical evaluation of integrals and tensor form factors entering the calculation of one-loop amplitudes with up to six external legs, written in Fortran 95.
+ pkgver = 1.3.3
+ pkgrel = 1
+ url = https://golem.hepforge.org/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = gcc-fortran
+ source = http://www.hepforge.org/archive/golem/golem95-1.3.3.tar.gz
+ sha256sums = 0f4f5ac3e33368e127dcaec23cc14b25e7cba614c614a5a871c60700d36b4fbd
+
+pkgname = golem95
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ded1e6ccc84b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.pkg.tar.xz
+golem95*.tar.gz \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..720faa63afaa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: JP-Ellis <josh@jpellis.me>
+
+pkgname=golem95
+pkgver=1.3.3
+pkgrel=1
+pkgdesc="A package for the numerical evaluation of integrals and tensor form factors entering the calculation of one-loop amplitudes with up to six external legs, written in Fortran 95."
+url="https://golem.hepforge.org/"
+arch=('i686' 'x86_64')
+license=('GPL3')
+makedepends=(
+ 'gcc-fortran'
+)
+source=("http://www.hepforge.org/archive/golem/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('0f4f5ac3e33368e127dcaec23cc14b25e7cba614c614a5a871c60700d36b4fbd')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ ./configure --prefix=/usr
+}
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ make install DESTDIR="${pkgdir}"
+}
+
+# Local Variables:
+# mode: sh
+# End:
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..42b6766051ca
--- /dev/null
+++ b/README.md
@@ -0,0 +1,36 @@
+Golem95
+=======
+
+[![AUR badge][AUR badge]][AUR]
+
+Golem95 installer Arch Linux.
+
+[Golem95][homepage] is a package for the numerical evaluation of integrals and
+tensor form factors entering the calculation of one-loop amplitudes with up to
+six external legs, written in Fortran 95.
+
+Golem95 performs the reduction to a certain set of basis integrals numerically,
+using a formalism where inverse Gram determinants can be avoided. The library
+contains massless as well as massive integrals and also can handle complex
+masses. Infrared and ultraviolet divergences are regulated by dimensional
+regularization. Integrals with tensor ranks exceeding the number of propagators
+are supported.
+
+For more details, see
+
+> Binoth, T., et al. "Golem95: a numerical program to calculate one-loop tensor
+> integrals with up to six external legs." *Computer Physics Communications*
+> 180.11 (2009): 2317-2330. [doi:10.1016/j.cpc.2009.06.024](https://doi.org/10.1016/j.cpc.2009.06.024)
+
+> Cullen, G., et al. "Golem95C: A library for one-loop integrals with complex
+> masses." *Computer Physics Communications* 182.10 (2011):
+> 2276-2284. [doi:10.1016/j.cpc.2011.05.015](https://doi.org/10.1016/j.cpc.2011.05.015)
+
+> Guillet, J. Ph, G. Heinrich, and J. F. von Soden-Fraunhofen. "Tools for NLO
+> automation: extension of the golem95C integral library." *Computer Physics
+> Communications* 185.6 (2014):
+> 1828-1834. [doi:10.1016/j.cpc.2014.03.009](https://doi.org/10.1016/j.cpc.2014.03.009)
+
+[homepage]: https://golem.hepforge.org/
+[AUR]: https://aur.archlinux.org/packages/golem95/
+[AUR badge]: https://img.shields.io/aur/version/golem95.svg