summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM. Greyson Christoforo2024-04-14 11:04:30 -0600
committerM. Greyson Christoforo2024-04-14 11:04:30 -0600
commita3dabc58350e25f142c953ac1769b3de292f44e4 (patch)
tree1cb05bedbef28b99220bcc859f99606d8fa17c4c
downloadaur-a3dabc58350e25f142c953ac1769b3de292f44e4.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD16
-rw-r--r--gollum-bin.install13
4 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..542cecd26381
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = gollum-bin
+ pkgdesc = A simple, Git-powered wiki with a sweet API and local frontend. Via upstream's bin
+ pkgver = 5.3.2
+ pkgrel = 1
+ url = http://github.com/gollum/gollum
+ install = gollum-bin.install
+ arch = x86_64
+ license = MIT
+ depends = java-runtime-headless
+ noextract = gollum-5.3.2.war
+ source = gollum-5.3.2.war::https://github.com/gollum/gollum/releases/download/v5.3.2/gollum.war
+ sha256sums = ce32a8bf4b2c29f22409598fb0d361487932a7ad05d28a495abf65b5179fec95
+
+pkgname = gollum-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..288f7c840c5c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+src/
+pkg/
+*.war
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e7fb0e43a66a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+pkgname=gollum-bin
+pkgver=5.3.2
+pkgrel=1
+pkgdesc="A simple, Git-powered wiki with a sweet API and local frontend. Via upstream's bin"
+arch=(x86_64)
+url='http://github.com/gollum/gollum'
+license=(MIT)
+depends=(java-runtime-headless)
+install=gollum-bin.install
+source=("gollum-${pkgver}.war::https://github.com/gollum/gollum/releases/download/v${pkgver}/gollum.war")
+noextract=("gollum-${pkgver}.war")
+sha256sums=('ce32a8bf4b2c29f22409598fb0d361487932a7ad05d28a495abf65b5179fec95')
+
+package() {
+ install -D -m644 gollum-${pkgver}.war "${pkgdir}/opt/gollum/gollum.war"
+}
diff --git a/gollum-bin.install b/gollum-bin.install
new file mode 100644
index 000000000000..9933c58d00d1
--- /dev/null
+++ b/gollum-bin.install
@@ -0,0 +1,13 @@
+print_instructions() {
+ echo "You can run the server like so:"
+ echo "java -jar /opt/gollum/gollum.war -S gollum <your-gollum-arguments-here>"
+ echo "see arguments here: https://github.com/gollum/gollum#configuration"
+}
+
+post_install() {
+ print_instructions
+}
+
+post_upgrade() {
+ print_instructions
+}