summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwojciechkepka2020-07-15 11:35:10 +0200
committerwojciechkepka2020-07-15 11:35:10 +0200
commitdb6c5ac086f705a0e1b54ec0676f09ebced9e311 (patch)
tree89d6387b34f892f1b6d24d432803a81f3181c16c
downloadaur-db6c5ac086f705a0e1b54ec0676f09ebced9e311.tar.gz
Add files
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..04ce0ec6a7b4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = gomd-git
+ pkgdesc = Quick webserver displaying formatted markdown files
+ pkgver = 20200715.a7237de
+ pkgrel = 1
+ url = https://github.com/wojciechkepka/gomd
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = sassc
+ makedepends = nodejs-cleancss-cli
+ makedepends = make
+ makedepends = go
+ provides = gomd
+ conflicts = gomd
+ source = gomd-git::git+https://github.com/wojciechkepka/gomd
+ sha1sums = SKIP
+
+pkgname = gomd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1362ebf1f68c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Wojciech Kepka <wojtek.kepka@protonmail.com>
+pkgname=gomd-git
+pkgver=20200715.a7237de
+pkgrel=1
+epoch=
+pkgdesc="Quick webserver displaying formatted markdown files"
+arch=('x86_64' 'i686')
+url="https://github.com/wojciechkepka/gomd"
+license=('MIT')
+depends=()
+makedepends=('sassc' 'nodejs-cleancss-cli' 'make' 'go')
+provides=("gomd")
+conflicts=("gomd")
+sha1sums=('SKIP')
+source=("$pkgname::git+https://github.com/wojciechkepka/gomd")
+
+build() {
+ cd "$pkgname"
+ make
+}
+
+pkgver() {
+ cd "$pkgname"
+ echo "$(git log -1 --format=%cd.%h --date=short|tr -d -)"
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm755 "gomd" "$pkgdir/usr/bin/gomd"
+}