summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2016-06-20 12:36:59 -0700
committerAndy Weidenbaum2016-06-20 12:36:59 -0700
commitbbf5cf115135ba55d475df759e696cecf50ab560 (patch)
tree2c7e9d6aa73449551784ab199dd60cfbc2bc8c02
downloadaur-bbf5cf115135ba55d475df759e696cecf50ab560.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD43
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ca7494249663
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Mon Jun 20 19:36:49 UTC 2016
+pkgbase = gomobile
+ pkgdesc = Tool for building and running mobile apps written in Go
+ pkgver = 20160620
+ pkgrel = 1
+ url = https://github.com/golang/mobile
+ arch = i686
+ arch = x86_64
+ license = custom:BSD
+ makedepends = git
+ makedepends = go
+ options = !strip
+ options = !emptydirs
+
+pkgname = gomobile
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..67a9b186b008
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=gomobile
+pkgver=20160620
+pkgrel=1
+pkgdesc="Tool for building and running mobile apps written in Go"
+arch=('i686' 'x86_64')
+makedepends=('git' 'go')
+url="https://github.com/golang/mobile"
+license=('custom:BSD')
+options=('!strip' '!emptydirs')
+
+pkgver() {
+ date +%Y%m%d
+}
+
+build() {
+ export GOPATH="$srcdir"
+
+ msg2 'Building...'
+ go get -v golang.org/x/mobile/cmd/gomobile
+}
+
+package() {
+ msg2 'Installing license...'
+ install -Dm 644 "$srcdir/src/golang.org/x/mobile"/{AUTHORS,LICENSE,PATENTS} \
+ -t "$pkgdir/usr/share/licenses/gomobile"
+
+ msg2 'Installing documentation...'
+ for _doc in CONTRIB* README.md; do
+ install -Dm 644 "$srcdir/src/golang.org/x/mobile"/$_doc \
+ -t "$pkgdir/usr/share/doc/gomobile"
+ done
+ cp -dpr --no-preserve=ownership "$srcdir/src/golang.org/x/mobile/doc" \
+ "$pkgdir/usr/share/doc/gomobile"
+
+ msg2 'Installing...'
+ install -Dm 755 "$srcdir/bin/gomobile" -t "$pkgdir/usr/bin"
+
+ msg2 'Cleaning up pkgdir...'
+ find "$pkgdir" -type d -name .git -exec rm -r '{}' +
+ find "$pkgdir" -type f -name .gitignore -exec rm -r '{}' +
+}