summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorty2020-07-30 18:55:17 +0200
committerWorty2020-07-30 18:55:17 +0200
commitf54f88d7ac3de2b3764d2177dbc5e44f9314024c (patch)
treeb7f491540ab07eb700b6af12a9a746f8bf66e360
downloadaur-f54f88d7ac3de2b3764d2177dbc5e44f9314024c.tar.gz
ver. 1.0.2 init
-rw-r--r--.SRCINFO16
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD24
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..585f08d9e0d8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gomp
+ pkgdesc = Git-based tool for comparing branches
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/MarkForged/GOMP
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/g/gomp/gomp-1.0.2.tar.gz
+ source = LICENSE
+ sha256sums = 6b399c252f983c5aa7133bb3bb4f51134a93f883f91a90be4f835d4091b6d0e7
+ sha256sums = 5eb2e11066350f22ddec76c580323277a87e132aa7487adbcb277e489fdae24d
+
+pkgname = gomp
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..18517ff9d69b
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2020 Markforged
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..03f0f72fbbe9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: w0rty <mawo97 at gmail.com>
+
+pkgname=gomp
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="Git-based tool for comparing branches"
+arch=('any')
+url="https://github.com/MarkForged/GOMP"
+license=('MIT')
+makedepends=('python-setuptools')
+depends=('python')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz" "LICENSE")
+sha256sums=('6b399c252f983c5aa7133bb3bb4f51134a93f883f91a90be4f835d4091b6d0e7' '5eb2e11066350f22ddec76c580323277a87e132aa7487adbcb277e489fdae24d')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 $srcdir/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}