summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraditya-K22021-12-17 01:55:40 +0530
committeraditya-K22021-12-17 01:55:40 +0530
commit301ac8cabd2d9ec0c9a59d5c1b0436b35c8edffd (patch)
tree557b1517ebf338d23137ba6e56af0a06e83e4bf9
parentf855810c2ec1aefb37877b0c27db0676d427f6ba (diff)
downloadaur-301ac8cabd2d9ec0c9a59d5c1b0436b35c8edffd.tar.gz
Making the Changes that were suggested
using pkgver() and changed the source from zip to git repo
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b84ad3101386..69e3462a5502 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = gomp-git
pkgdesc = MPD client inspired by ncmpcpp written in GO.
- pkgver = 0.1
+ pkgver = r196.0db49ca
pkgrel = 1
url = https://github.com/aditya-K2/gomp
arch = any
license = GPL
makedepends = go
- source = https://github.com/aditya-K2/gomp/archive/refs/heads/master.zip
+ source = git+https://github.com/aditya-K2/gomp/
sha256sums = SKIP
pkgname = gomp-git
diff --git a/PKGBUILD b/PKGBUILD
index 8baa1b9257f1..ef27db93c758 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,26 @@
# Maintainer: aditya-K2 <adityakurdunkar2@gmail.com>
pkgname=gomp-git
-pkgver=0.1
+pkgver=r196.0db49ca
pkgrel=1
pkgdesc='MPD client inspired by ncmpcpp written in GO.'
arch=('any')
url="https://github.com/aditya-K2/gomp"
license=('GPL')
makedepends=('go')
-source=("https://github.com/aditya-K2/gomp/archive/refs/heads/master.zip")
+source=("git+https://github.com/aditya-K2/gomp/")
sha256sums=('SKIP')
+pkgver() {
+ cd "${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
build() {
- cd "${pkgname%-git}-master"
+ cd "${pkgname%-git}"
go build
}
package() {
- cd "${pkgname%-git}-master"
+ cd "${pkgname%-git}"
install -Dm 655 gomp -t "${pkgdir}/usr/bin"
}