summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraditya-K22021-12-17 01:24:08 +0530
committeraditya-K22021-12-17 01:24:08 +0530
commitf855810c2ec1aefb37877b0c27db0676d427f6ba (patch)
treec8647e08dbdec76568e782231613c660b3165769
downloadaur-f855810c2ec1aefb37877b0c27db0676d427f6ba.tar.gz
inital commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b84ad3101386
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = gomp-git
+ pkgdesc = MPD client inspired by ncmpcpp written in GO.
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/aditya-K2/gomp
+ arch = any
+ license = GPL
+ makedepends = go
+ source = https://github.com/aditya-K2/gomp/archive/refs/heads/master.zip
+ sha256sums = SKIP
+
+pkgname = gomp-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8baa1b9257f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: aditya-K2 <adityakurdunkar2@gmail.com>
+pkgname=gomp-git
+pkgver=0.1
+pkgrel=1
+pkgdesc='MPD client inspired by ncmpcpp written in GO.'
+arch=('any')
+url="https://github.com/aditya-K2/gomp"
+license=('GPL')
+makedepends=('go')
+source=("https://github.com/aditya-K2/gomp/archive/refs/heads/master.zip")
+sha256sums=('SKIP')
+
+build() {
+ cd "${pkgname%-git}-master"
+ go build
+}
+
+package() {
+ cd "${pkgname%-git}-master"
+ install -Dm 655 gomp -t "${pkgdir}/usr/bin"
+}