summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorraziman2020-08-22 21:06:15 +0800
committerraziman2020-08-22 21:06:15 +0800
commit0747e576844404708c59a484a1bf93dc40bf2eea (patch)
tree7d4496625b4ee9e3367ef2967be8c252438fe5df
downloadaur-0747e576844404708c59a484a1bf93dc40bf2eea.tar.gz
initial package creatin
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD26
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f31b746dc907
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = gomu
+ pkgdesc = Terminal User Interface (TUI) Music Player
+ pkgver = 1.5.4
+ pkgrel = 1
+ url = https://github.com/issadarkthing/gomu
+ arch = x86_64
+ license = GPL
+ makedepends = go
+ makedepends = git
+ depends = alsa-lib
+ depends = youtube-dl
+ depends = noto-fonts-emoji
+ optdepends = fzf
+ conflicts = gomu-git
+ conflicts = gomu-bin
+ source = gomu-1.5.4.tar.gz::https://github.com/issadarkthing/gomu/archive/v1.5.4.tar.gz
+ md5sums = 23393d854b450485279ac25c69157719
+
+pkgname = gomu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ddb5a3730cd8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Raziman Mahathir <raziman.mahathir@gmail.com>
+pkgname='gomu'
+pkgver=1.5.4
+pkgrel=1
+pkgdesc="Terminal User Interface (TUI) Music Player"
+arch=('x86_64')
+url="https://github.com/issadarkthing/gomu"
+license=('GPL')
+groups=()
+depends=('alsa-lib' 'youtube-dl' 'noto-fonts-emoji')
+makedepends=('go' 'git')
+optdepends=('fzf')
+conflicts=('gomu-git' 'gomu-bin')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/issadarkthing/$pkgname/archive/v$pkgver.tar.gz")
+md5sums=('23393d854b450485279ac25c69157719')
+
+
+build() {
+ cd "$pkgname-$pkgver"
+ make build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 ./bin/gomu "$pkgdir/usr/bin/gomu"
+}