summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorraziman2020-08-22 23:10:50 +0800
committerraziman2020-08-22 23:10:50 +0800
commitabd13272a765815a2f505de57503384d5cb72b63 (patch)
tree3b2d67693e25d66dc225d191f18e0339f930824d
parent0747e576844404708c59a484a1bf93dc40bf2eea (diff)
downloadaur-abd13272a765815a2f505de57503384d5cb72b63.tar.gz
remove testing in Makefile
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f31b746dc907..1cefbbc05719 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gomu
pkgdesc = Terminal User Interface (TUI) Music Player
- pkgver = 1.5.4
- pkgrel = 1
+ pkgver = v1.5.5
+ pkgrel = 2
url = https://github.com/issadarkthing/gomu
arch = x86_64
license = GPL
@@ -13,8 +13,8 @@ pkgbase = gomu
optdepends = fzf
conflicts = gomu-git
conflicts = gomu-bin
- source = gomu-1.5.4.tar.gz::https://github.com/issadarkthing/gomu/archive/v1.5.4.tar.gz
- md5sums = 23393d854b450485279ac25c69157719
+ source = git://github.com/issadarkthing/gomu.git
+ md5sums = SKIP
pkgname = gomu
diff --git a/PKGBUILD b/PKGBUILD
index ddb5a3730cd8..4e371c996c7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Raziman Mahathir <raziman.mahathir@gmail.com>
pkgname='gomu'
-pkgver=1.5.4
-pkgrel=1
+pkgver=v1.5.5
+pkgrel=2
pkgdesc="Terminal User Interface (TUI) Music Player"
arch=('x86_64')
url="https://github.com/issadarkthing/gomu"
@@ -11,16 +11,20 @@ depends=('alsa-lib' 'youtube-dl' 'noto-fonts-emoji')
makedepends=('go' 'git')
optdepends=('fzf')
conflicts=('gomu-git' 'gomu-bin')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/issadarkthing/$pkgname/archive/v$pkgver.tar.gz")
-md5sums=('23393d854b450485279ac25c69157719')
+source=("git://github.com/issadarkthing/gomu.git")
+md5sums=('SKIP')
+pkgver() {
+ cd "$pkgname"
+ git describe --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
build() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname"
make build
}
package() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname"
install -Dm755 ./bin/gomu "$pkgdir/usr/bin/gomu"
}