summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorraziman2020-08-23 11:42:44 +0800
committerraziman2020-08-23 11:42:44 +0800
commitc5d2a242cbf0c64674c19177ae5b55352096e2b2 (patch)
tree12721600fcf25fe4f4b7650d97740194d9d2fab1
parentabd13272a765815a2f505de57503384d5cb72b63 (diff)
downloadaur-c5d2a242cbf0c64674c19177ae5b55352096e2b2.tar.gz
add checksum and change source
-rw-r--r--PKGBUILD14
1 files changed, 5 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4e371c996c7e..889cccd3fe59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Raziman Mahathir <raziman.mahathir@gmail.com>
pkgname='gomu'
-pkgver=v1.5.5
+pkgver=1.5.5
pkgrel=2
pkgdesc="Terminal User Interface (TUI) Music Player"
arch=('x86_64')
@@ -11,20 +11,16 @@ depends=('alsa-lib' 'youtube-dl' 'noto-fonts-emoji')
makedepends=('go' 'git')
optdepends=('fzf')
conflicts=('gomu-git' 'gomu-bin')
-source=("git://github.com/issadarkthing/gomu.git")
-md5sums=('SKIP')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/issadarkthing/$pkgname/archive/v$pkgver.tar.gz")
+md5sums=('0c386dac1666fbb0d26738686f1e0198')
-pkgver() {
- cd "$pkgname"
- git describe --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
build() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
make build
}
package() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
install -Dm755 ./bin/gomu "$pkgdir/usr/bin/gomu"
}