summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAinola2015-06-08 11:49:53 -0600
committerAinola2015-06-08 11:49:53 -0600
commit06ce671628cb8d3ab62906292c19d849a5ea4a6d (patch)
tree096bba032a50d1d8212b6405cb98efb47752b21d
downloadaur-06ce671628cb8d3ab62906292c19d849a5ea4a6d.tar.gz
initial
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD52
-rw-r--r--gone-home-hib.desktop10
-rw-r--r--gone-home-hib.install6
4 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e5fdb51b792
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = gone-home-hib
+ pkgdesc = Gone home is an interactive exploration simulator by Fullbright.
+ pkgver = 1.1
+ pkgrel = 2
+ url = http://www.gonehomegame.com/
+ install = gone-home-hib.install
+ arch = i686
+ arch = x86_64
+ license = custom: commercial
+ depends = glu
+ depends = libxext
+ depends = libxcursor
+ source = hib://GoneHome_v1.1.tar.gz
+ source = gone-home-hib.desktop
+ source = gone-home-hib.install
+ sha256sums = ecd01fcde184f7d1937579e7d5d4a791007887b88f9baa10039747166bb2d097
+ sha256sums = dea74a9436b2b37a63265c0606195293cb751855e2de473e678ab85600c92053
+ sha256sums = ea11e510a7c52e485cf1e87eb985691029b62fc694830a0c57f14b4173ac8edd
+
+pkgname = gone-home-hib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1de4753a8ad5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: ainola <opp310@alh.rqh> (ROT13)
+
+pkgname=gone-home-hib
+pkgver=1.1
+pkgrel=2
+pkgdesc="Gone home is an interactive exploration simulator by Fullbright."
+arch=('i686' 'x86_64')
+url="http://www.gonehomegame.com/"
+license=('custom: commercial')
+depends=('glu' 'libxext' 'libxcursor')
+source=("hib://GoneHome_v${pkgver}.tar.gz"
+ "${pkgname}.desktop"
+ "${pkgname}.install")
+sha256sums=("ecd01fcde184f7d1937579e7d5d4a791007887b88f9baa10039747166bb2d097"
+ "dea74a9436b2b37a63265c0606195293cb751855e2de473e678ab85600c92053"
+ "ea11e510a7c52e485cf1e87eb985691029b62fc694830a0c57f14b4173ac8edd")
+install=("${pkgname}.install")
+[ "$CARCH" == "x86_64" ] && _arch="x86_64" || _arch="x86"
+# Prevent compressing final package
+PKGEXT='.pkg.tar'
+
+# You need to download the Humble Bundle file manually or you can configure
+# DLAGENTS in makepkg.conf to auto-download.
+#
+# For example, hib-dlagent (https://aur.archlinux.org/packages/hib-dlagent/)
+# can be used to download files. Add something like this in your makepkg.conf
+# (you need to tweak the options to your needs):
+# DLAGENTS+=('hib::/usr/bin/hib-dlagent -k $KEY -u $USER -p $PASS -o %o %u')
+#
+# The following is just a fallback to the above to notify the user:
+DLAGENTS+=("hib::/usr/bin/echo %u - This is is not a real URL, you need to download the humble bundle file manually to \"$PWD\" or setup a hib:// DLAGENT. Read this PKGBUILD for more information.")
+
+package() {
+ # Launcher and Data
+ install -Dm755 "${srcdir}/GoneHome.${_arch}" "${pkgdir}/opt/${pkgname}/GoneHome.${_arch}"
+ mv "${srcdir}/GoneHome_Data" "${srcdir}/"*.txt "${pkgdir}/opt/${pkgname}/"
+
+ # Install Binaries/Launchers
+ mkdir -p "$pkgdir/usr/bin"
+ ln -s "/opt/${pkgname}/GoneHome.${_arch}" "${pkgdir}/usr/bin/${pkgname}"
+
+ # Desktop Integration
+ mkdir -p "$pkgdir/usr/share/pixmaps"
+ ln -s "/opt/${pkgname}/GoneHome_Data/Resources/UnityPlayer.png" \
+ "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ # Fix wonky permissions
+ find "${pkgdir}/opt/${pkgname}" -type d -exec chmod 755 {} \;
+ find "${pkgdir}/opt/${pkgname}" -type f -exec chmod 644 {} \;
+ chmod 755 "${pkgdir}/opt/${pkgname}/GoneHome.${_arch}"
+}
diff --git a/gone-home-hib.desktop b/gone-home-hib.desktop
new file mode 100644
index 000000000000..f43fe59fa6f4
--- /dev/null
+++ b/gone-home-hib.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Gone Home
+Comment=Play Gone Home
+Exec=gone-home-hib
+Icon=gone-home-hib
+Type=Application
+Terminal=false
+StartupNotify=true
+Categories=Game;AudioVideo;
+Encoding=UTF-8
diff --git a/gone-home-hib.install b/gone-home-hib.install
new file mode 100644
index 000000000000..3d7fc8dd9910
--- /dev/null
+++ b/gone-home-hib.install
@@ -0,0 +1,6 @@
+post_install(){
+ echo ""
+ echo ">> Fullscreen mode may present odd mouse issues."
+ echo ">> If any do occur try running the game in windowed mode."
+ echo ""
+}