summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitri Pertin2020-04-23 23:15:26 +0200
committerDimitri Pertin2020-04-23 23:26:00 +0200
commit60068c75bd5815b5435443cf13a490376e2de3b5 (patch)
tree949e06d33a4db69e08fce9964450e06ee7b6e3df
parent3709364b3c434f2a2a32dc2abacc6955ae22014f (diff)
downloadaur-60068c75bd5815b5435443cf13a490376e2de3b5.tar.gz
Add support for Drone CI
Drone is a CI/CD platform used here to check for each commit if the package can be built. Operations are done inside a Docker container based on: https://hub.docker.com/r/imrehg/archlinux-makepkg
-rw-r--r--.drone.yml18
-rw-r--r--README.md2
2 files changed, 20 insertions, 0 deletions
diff --git a/.drone.yml b/.drone.yml
new file mode 100644
index 000000000000..153d6fdd46e6
--- /dev/null
+++ b/.drone.yml
@@ -0,0 +1,18 @@
+kind: pipeline
+type: docker
+name: default
+
+steps:
+- name: fixperms
+ image: imrehg/archlinux-makepkg
+ user: root
+ commands:
+ - chown -R builder:builder .
+- name: build
+ image: imrehg/archlinux-makepkg
+ commands:
+ - yay -Suy --noconfirm
+ - namcap PKGBUILD
+ - makepkg -sci --noconfirm
+ - namcap *.pkg.tar.xz
+
diff --git a/README.md b/README.md
index 8327f138e08d..f27f5e331882 100644
--- a/README.md
+++ b/README.md
@@ -1,6 +1,8 @@
# AUR Gonic PKGBUILD
+[![Build Status](https://cloud.drone.io/api/badges/dpertin/aur-gonic/status.svg)](https://cloud.drone.io/dpertin/aur-gonic)
+
This repo contains the required files to generate an Archlinux package of
[gonic](https://github.com/sentriz/gonic),
a lightweight music streaming server written in Go, which implements the