summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Epplée2021-10-11 16:21:12 +0200
committerRafael Epplée2021-10-11 16:21:12 +0200
commitaf31efcb4d80007f7a73f549de69d016f158f056 (patch)
tree429540c4f53a67117182788f9dc01597b03958d1
parent9d6f5778a0f937d0fe29689eea4965463bcb26e6 (diff)
downloadaur-af31efcb4d80007f7a73f549de69d016f158f056.tar.gz
Update to 0.14.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD13
-rw-r--r--gonic.config.patch10
-rw-r--r--gonic.service22
-rw-r--r--gonic.service.patch19
5 files changed, 20 insertions, 56 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d02709abbf9a..39c0e78193dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,28 @@
pkgbase = gonic
pkgdesc = A lightweight music streaming server which implements the Subsonic API
- pkgver = 0.13.1
+ pkgver = 0.14.0
pkgrel = 1
url = https://github.com/sentriz/gonic
install = gonic.install
arch = x86_64
license = GPL3
makedepends = go
+ makedepends = zlib
depends = alsa-lib
depends = gcc-libs
depends = sqlite
depends = taglib
optdepends = ffmpeg: on-the-fly audio transcoding and caching
backup = var/lib/gonic/config
- source = gonic-0.13.1.tar.gz::https://github.com/sentriz/gonic/archive/v0.13.1.tar.gz
- source = gonic.config.patch
+ source = gonic-0.14.0.tar.gz::https://github.com/sentriz/gonic/archive/v0.14.0.tar.gz
source = gonic.install
source = gonic.service.patch
source = gonic.sysusers
source = gonic.tmpfiles
- md5sums = 29d301c749f1654e8bbc0835d3250e08
- md5sums = 240faa29e218962b1ed6c4ce4d138248
+ md5sums = 26c41e119263d439eb0e5f201118849b
md5sums = d6e8eda0411af60e613819ac957fcc56
- md5sums = c8f973db7a107f8653f7ff36555ce1a0
+ md5sums = 18458d6d039609f3068248bf3df44782
md5sums = 6ca6715be2cdd424846f7b37b98905f6
md5sums = 487fe9a172e33d86514cf3dbb3b629b8
pkgname = gonic
-
diff --git a/PKGBUILD b/PKGBUILD
index 2010f157d51c..4d425ffb6c55 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,29 @@
-# Maintainer: Dimitri Pertin <pertin (dot) dimitri (at) protonmail (dot) com>
+# Maintainer: Rafael Epplée <aur (at) rafa (dot) ee>
pkgname=gonic
-pkgver=0.13.1
+pkgver=0.14.0
pkgrel=1
pkgdesc='A lightweight music streaming server which implements the Subsonic API'
arch=('x86_64')
depends=('alsa-lib' 'gcc-libs' 'sqlite' 'taglib')
-makedepends=('go')
+makedepends=('go' 'zlib')
optdepends=('ffmpeg: on-the-fly audio transcoding and caching')
url='https://github.com/sentriz/gonic'
license=('GPL3')
backup=("var/lib/gonic/config")
install="$pkgname.install"
source=("$pkgname-$pkgver.tar.gz::https://github.com/sentriz/gonic/archive/v$pkgver.tar.gz"
- "$pkgname.config.patch"
"$pkgname.install"
"$pkgname.service.patch"
"$pkgname.sysusers"
"$pkgname.tmpfiles")
-md5sums=('29d301c749f1654e8bbc0835d3250e08'
- '240faa29e218962b1ed6c4ce4d138248'
+md5sums=('26c41e119263d439eb0e5f201118849b'
'd6e8eda0411af60e613819ac957fcc56'
- 'c8f973db7a107f8653f7ff36555ce1a0'
+ '18458d6d039609f3068248bf3df44782'
'6ca6715be2cdd424846f7b37b98905f6'
'487fe9a172e33d86514cf3dbb3b629b8')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
- patch --forward --strip=1 -i "../$pkgname.config.patch"
patch --forward --strip=1 -i "../$pkgname.service.patch"
}
diff --git a/gonic.config.patch b/gonic.config.patch
deleted file mode 100644
index 96ef2e1a5781..000000000000
--- a/gonic.config.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/contrib/config
-+++ b/contrib/config
-@@ -1,6 +1,6 @@
- music-path
- cache-path /tmp/gonic_cache
--db-path /var/gonic/gonic.db
-+db-path /var/lib/gonic/gonic.db
- jukebox-enabled false
- listen-addr 127.0.0.1:4747
- proxy-prefix /gonic
diff --git a/gonic.service b/gonic.service
index 6f476c68edbc..a443ea3ac370 100644
--- a/gonic.service
+++ b/gonic.service
@@ -1,26 +1,16 @@
[Unit]
-Description=Gonic: Subsonic server API implementation
-Wants=network-online.target
-After=network-online.target
+Description=gonic service
+After=network.target
[Service]
+Type=simple
User=gonic
Group=gonic
-Type=simple
-ExecStart=/usr/bin/gonic
-
-# Required variable:
-Environment=GONIC_MUSIC_PATH=/home/
+Restart=on-failure
+RestartSec=10
-# Optional variables:
-Environment=GONIC_DB_PATH=/var/lib/gonic/gonic.db
-#Environment=GONIC_CACHE_PATH=/var/lib/gonic/gonic_cache
-#Environment=GONIC_LISTEN_ADDR=0.0.0.0:4747
-#Environment=GONIC_PROXY_PREFIX=
-#Environment=GONIC_SCAN_INTERVAL=
-#Environment=GONIC_JUKEBOX_ENABLED=false
+ExecStart=/usr/bin/gonic -config-path /var/lib/gonic/config
[Install]
WantedBy=multi-user.target
-
diff --git a/gonic.service.patch b/gonic.service.patch
index d0090b8fb154..4a7318a71eca 100644
--- a/gonic.service.patch
+++ b/gonic.service.patch
@@ -2,28 +2,17 @@
+++ b/contrib/gonic.service
@@ -1,6 +1,5 @@
[Unit]
- Description=Gonic service
--ConditionPathExists=/var/gonic/gonic
+ Description=gonic service
+-ConditionPathExists=/var/lib/gonic/
After=network.target
[Service]
-@@ -12,17 +11,8 @@
+@@ -11,7 +10,7 @@
Restart=on-failure
RestartSec=10
--WorkingDirectory=/var/gonic/
--ExecStart=/var/gonic/gonic -config-path /var/gonic/config
+-ExecStart=/usr/local/bin/gonic -config-path /etc/gonic/config
+ExecStart=/usr/bin/gonic -config-path /var/lib/gonic/config
--
--# make sure log directory exists and owned by syslog
--PermissionsStartOnly=true
--ExecStartPre=/bin/mkdir -p /var/log/gonic
--ExecStartPre=/bin/chown syslog:adm /var/log/gonic
--ExecStartPre=/bin/chmod 755 /var/log/gonic
--StandardOutput=syslog
--StandardError=syslog
--SyslogIdentifier=sleepservice
[Install]
WantedBy=multi-user.target
-+