summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanish Prakash2018-07-29 13:09:58 +0000
committerDanish Prakash2018-07-29 13:11:01 +0000
commit29eaf09cd1bcf1a43b8da7468e91e56c8f739a41 (patch)
tree96a94360209e36df4a4663a3c92a5a41c7c7939c
downloadaur-29eaf09cd1bcf1a43b8da7468e91e56c8f739a41.tar.gz
adds pkgbuild, srcinfo
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..30a4c86891d0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = goodreadsh
+ pkgdesc = Command line interface for Goodreads
+ pkgver = 1.16
+ pkgrel = 1
+ url = https://github.com/prakashdanish/goodreadsh
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ provides = goodreadsh
+ source = git+https://github.com/prakashdanish/goodreadsh.git#branch=master
+ md5sums = SKIP
+
+pkgname = goodreadsh
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3e662a4c0d6b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Danish Prakash <danishprakash at outlook dot com>
+_gitrepository='goodreadsh'
+_gitbranch='master'
+pkgname='goodreadsh'
+pkgver=1.0.1
+pkgrel=1
+pkgdesc='Command line interface for Goodreads'
+arch=('i686' 'x86_64')
+url='https://github.com/prakashdanish/goodreadsh'
+license=('MIT')
+depends=()
+makedepends=('git')
+provides=('goodreadsh')
+source=("git+https://github.com/prakashdanish/${_gitrepository}.git#branch=${_gitbranch}")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_gitrepository}"
+ printf '1.%s\n' "$(( $(git rev-list --count master) ))"
+}
+
+package() {
+ cd "${srcdir}/${_gitrepository}"
+ install -Dm755 './goodreads' "${pkgdir}/usr/bin/goodreads"
+}