summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÉtienne Deparis2022-03-16 12:32:54 +0100
committerÉtienne Deparis2022-03-16 12:32:54 +0100
commit0219a2ba691d57e139f0dce0588c4f327f2134e8 (patch)
treeab07121d6988ee4a277fbc6a6f196c42ba64aaba
parent84896d2eda0ca558b7c518ecaddc9e004c1d7c73 (diff)
downloadaur-0219a2ba691d57e139f0dce0588c4f327f2134e8.tar.gz
0.7.3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ec915cb184e..6debd8dcb49a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by makepkg 6.0.1
-# Tue Nov 16 16:38:21 UTC 2021
+# Wed Mar 16 11:30:25 UTC 2022
pkgbase = goodvibes
pkgdesc = Lightweight internet radio player
- pkgver = 0.7.2
+ pkgver = 0.7.3
pkgrel = 1
url = https://gitlab.com/goodvibes/goodvibes
arch = i686
@@ -14,7 +14,7 @@ pkgbase = goodvibes
depends = gst-plugins-bad
depends = gst-plugins-good
depends = gst-plugins-ugly
- source = https://gitlab.com/goodvibes/goodvibes/-/archive/v0.7.2/goodvibes-v0.7.2.tar.gz
- sha256sums = 5f96ba7b8654f331181c8ee0e697d042a195406712a547e7954159e5d66795ba
+ source = https://gitlab.com/goodvibes/goodvibes/-/archive/v0.7.3/goodvibes-v0.7.3.tar.gz
+ sha256sums = 14a2c70fa69eb5d69338df3782637e705b0baca5365e5a4fc2d2e45ac6c18414
pkgname = goodvibes
diff --git a/PKGBUILD b/PKGBUILD
index 7e2bf54a0fb0..87abfce03ff2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Étienne Deparis <etienne@depar.is>
pkgname=goodvibes
-pkgver=0.7.2
+pkgver=0.7.3
pkgrel=1
pkgdesc="Lightweight internet radio player"
arch=('i686' 'x86_64')
@@ -10,16 +10,20 @@ license=('GPL')
depends=("libkeybinder3" "gst-plugins-base" "gst-plugins-bad" "gst-plugins-good" "gst-plugins-ugly")
makedepends=("meson")
source=("https://gitlab.com/${pkgname}/${pkgname}/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.gz")
-sha256sums=('5f96ba7b8654f331181c8ee0e697d042a195406712a547e7954159e5d66795ba')
+sha256sums=('14a2c70fa69eb5d69338df3782637e705b0baca5365e5a4fc2d2e45ac6c18414')
+
+prepare() {
+ # Remove broken weird git thing
+ sed -i 140,161d "$pkgname-v$pkgver/meson.build"
+ # Remove tests
+ sed -i 94,104d "$pkgname-v$pkgver/meson.build"
+}
build() {
- cd "$srcdir/$pkgname-v$pkgver"
- meson --prefix=/usr build
- cd build
- ninja
+ arch-meson -D tests=false "$pkgname-v$pkgver" build
+ ninja -C build
}
package() {
- cd "$srcdir/$pkgname-v$pkgver/build"
- DESTDIR="$pkgdir" ninja install
+ DESTDIR="$pkgdir" ninja -C build install
}