summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÉtienne Deparis2018-08-19 16:05:37 +0200
committerÉtienne Deparis2018-08-19 16:05:37 +0200
commitf7009d0606830ad910fb1873990ad181ad948f88 (patch)
treefd6a7e5fcf267abad6fe21a12ca5a7d991857ce3
parent67447054e1e70d86ed59937e77fde2d296a52fb4 (diff)
downloadaur-f7009d0606830ad910fb1873990ad181ad948f88.tar.gz
0.4-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 19 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 267dd678d5b8..ad8b2868fc02 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,20 @@
-# Generated by makepkg 5.0.2
-# Mon May 21 14:37:18 UTC 2018
+# Generated by makepkg 5.1.1
+# Sun Aug 19 14:05:07 UTC 2018
pkgbase = goodvibes
pkgdesc = Lightweight internet radio player
- pkgver = 0.3.7
+ pkgver = 0.4
pkgrel = 1
- url = https://github.com/elboulangero/goodvibes
+ url = https://gitlab.com/goodvibes/goodvibes
arch = i686
arch = x86_64
license = GPL
- depends = glib2
- depends = dconf
- depends = gtk3
- depends = libsoup
+ makedepends = meson
depends = libkeybinder3
depends = gst-plugins-base
depends = gst-plugins-good
depends = gst-plugins-ugly
- source = https://github.com/elboulangero/goodvibes/archive/v0.3.7.tar.gz
- sha256sums = 610f3a3cf1332b6894b9b851605dd3a97dcaf9f24076c98a2af65a7eb50f7f27
+ source = https://gitlab.com/goodvibes/goodvibes/-/archive/v0.4/goodvibes-v0.4.tar.gz
+ sha256sums = 937969f0a6666173196eae31b0ba5d2e149fa71b623f702502cb160ce0062c95
pkgname = goodvibes
diff --git a/PKGBUILD b/PKGBUILD
index f75b018d17ef..5b47139da9a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,25 @@
# Maintainer: Étienne Deparis <etienne@depar.is>
pkgname=goodvibes
-pkgver=0.3.7
+pkgver=0.4
pkgrel=1
pkgdesc="Lightweight internet radio player"
arch=('i686' 'x86_64')
-url="https://github.com/elboulangero/goodvibes"
+url="https://gitlab.com/goodvibes/goodvibes"
license=('GPL')
-depends=("glib2" "dconf" "gtk3" "libsoup" "libkeybinder3"
- "gst-plugins-base" "gst-plugins-good" "gst-plugins-ugly")
-source=("https://github.com/elboulangero/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('610f3a3cf1332b6894b9b851605dd3a97dcaf9f24076c98a2af65a7eb50f7f27')
+depends=("libkeybinder3" "gst-plugins-base" "gst-plugins-good" "gst-plugins-ugly")
+makedepends=("meson")
+source=("https://gitlab.com/${pkgname}/${pkgname}/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.gz")
+sha256sums=('937969f0a6666173196eae31b0ba5d2e149fa71b623f702502cb160ce0062c95')
build() {
- cd "$srcdir/$pkgname-$pkgver"
-
- ./autogen.sh
- ./configure --prefix=/usr --enable-all
- make
+ cd "$srcdir/$pkgname-v$pkgver"
+ meson --prefix=/usr build
+ cd build
+ ninja
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
-
- make DESTDIR="$pkgdir" install
+ cd "$srcdir/$pkgname-v$pkgver/build"
+ DESTDIR="$pkgdir" ninja install
}