summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-11-02 09:38:20 +0800
committerzxp198210052023-11-02 09:38:20 +0800
commit6624bf9dd95fc48d82399b2db37df7d66e04d2af (patch)
treec6743da2432f52ee91a0ccf4964032ac7097ae61
parent4c0a1bdd52a346e2ad9433074e3101d0186398ad (diff)
downloadaur-6624bf9dd95fc48d82399b2db37df7d66e04d2af.tar.gz
update to 1.0.0
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD31
-rw-r--r--goofcord.sh6
3 files changed, 33 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d5c40b3c962..cc6537c6169c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,25 @@
pkgbase = goofcord-bin
pkgdesc = Take control of your Discord experience with GoofCord – the highly configurable and privacy first discord client.
- pkgver = 0.7.5
+ pkgver = 1.0.0
pkgrel = 1
url = https://github.com/Milkshiift/GoofCord
+ arch = aarch64
+ arch = armv7h
arch = x86_64
license = custom::OSL3
depends = bash
- depends = electron26
- provides = goofcord=0.7.5
+ depends = electron27
+ provides = goofcord=1.0.0
conflicts = goofcord
- source = goofcord-0.7.5.AppImage::https://github.com/Milkshiift/GoofCord/releases/download/v0.7.5/GoofCord-0.7.5-linux-x86_64.AppImage
- source = LICENSE::https://raw.githubusercontent.com/Milkshiift/GoofCord/v0.7.5/LICENSE
+ source = LICENSE::https://raw.githubusercontent.com/Milkshiift/GoofCord/v1.0.0/LICENSE
source = goofcord.sh
- sha256sums = 0b6dcf2577242582bbc0cc3f3251892866dfa4aea9f9be97de0dfa4e2c8cb8e0
sha256sums = 4e7f66aa93929feee2db20f14f871e7ddcc69236b0ecfb79a19ade9b859daf51
- sha256sums = aea4a3b6cf7aac399225798877e2c711426f971eb411fb604f44b08568a40802
+ sha256sums = dbb6a83ce037d6d6208835349dfd29a53c9a44cb96acdc89543b1f1bd3877f3e
+ source_aarch64 = goofcord-1.0.0-aarch64.deb::https://github.com/Milkshiift/GoofCord/releases/download/v1.0.0/GoofCord-1.0.0-linux-arm64.deb
+ sha256sums_aarch64 = f0ef6096ef2f477b7fa18101a96db8ba43c55d2bf2009b097b650de59074f5a9
+ source_armv7h = goofcord-1.0.0-armv7h.deb::https://github.com/Milkshiift/GoofCord/releases/download/v1.0.0/GoofCord-1.0.0-linux-armv7l.deb
+ sha256sums_armv7h = 29cb62fd54cb61ceac9042ccfe4a17f6c6864ca8de17964f25587a4895bcdf65
+ source_x86_64 = goofcord-1.0.0-x86_64.deb::https://github.com/Milkshiift/GoofCord/releases/download/v1.0.0/GoofCord-1.0.0-linux-amd64.deb
+ sha256sums_x86_64 = 8a2b632d9cec7ac4099940f0d59aa75b8461e9a4784aa25c6af53c498efde160
pkgname = goofcord-bin
diff --git a/PKGBUILD b/PKGBUILD
index 5f78941253ab..fc58003bd68e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,42 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=goofcord-bin
_pkgname=GoofCord
-pkgver=0.7.5
+pkgver=1.0.0
pkgrel=1
pkgdesc="Take control of your Discord experience with GoofCord – the highly configurable and privacy first discord client."
-arch=('x86_64')
+arch=('aarch64' 'armv7h' 'x86_64')
url="https://github.com/Milkshiift/GoofCord"
license=("custom::OSL3")
conflicts=("${pkgname%-bin}")
provides=("${pkgname%-bin}=${pkgver}")
depends=(
'bash'
- 'electron26'
+ 'electron27'
)
+source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.deb::${url}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-linux-arm64.deb")
+source_armv7h=("${pkgname%-bin}-${pkgver}-armv7h.deb::${url}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-linux-armv7l.deb")
+source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.deb::${url}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-linux-amd64.deb")
source=(
- "${pkgname%-bin}-${pkgver}.AppImage::${url}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-linux-${CARCH}.AppImage"
"LICENSE::https://raw.githubusercontent.com/Milkshiift/GoofCord/v${pkgver}/LICENSE"
"${pkgname%-bin}.sh"
)
-sha256sums=('0b6dcf2577242582bbc0cc3f3251892866dfa4aea9f9be97de0dfa4e2c8cb8e0'
- '4e7f66aa93929feee2db20f14f871e7ddcc69236b0ecfb79a19ade9b859daf51'
- 'aea4a3b6cf7aac399225798877e2c711426f971eb411fb604f44b08568a40802')
+sha256sums=('4e7f66aa93929feee2db20f14f871e7ddcc69236b0ecfb79a19ade9b859daf51'
+ 'dbb6a83ce037d6d6208835349dfd29a53c9a44cb96acdc89543b1f1bd3877f3e')
+sha256sums_aarch64=('f0ef6096ef2f477b7fa18101a96db8ba43c55d2bf2009b097b650de59074f5a9')
+sha256sums_armv7h=('29cb62fd54cb61ceac9042ccfe4a17f6c6864ca8de17964f25587a4895bcdf65')
+sha256sums_x86_64=('8a2b632d9cec7ac4099940f0d59aa75b8461e9a4784aa25c6af53c498efde160')
build() {
- chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
- "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
- sed "s|AppRun --no-sandbox %U|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
+ bsdtar -xf "${srcdir}/data.tar.xz"
+ sed "s|/opt/${_pkgname}/${pkgname%-bin} %U|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
- install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
- install -Dm644 "${srcdir}/squashfs-root/usr/lib/"* -t "${pkgdir}/usr/lib/${pkgname%-bin}/lib"
+ install -Dm644 "${srcdir}/opt/${_pkgname}/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
+ cp -r "${srcdir}/opt/${_pkgname}/resources/app.asar.unpacked" "${pkgdir}/usr/lib/${pkgname%-bin}"
for _icons in 16x16 32x32 48x48 64x64 128x128 256x256 512x512;do
- install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
+ install -Dm644 "${srcdir}/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
-t "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps"
done
- install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
} \ No newline at end of file
diff --git a/goofcord.sh b/goofcord.sh
index 54c36e7719fd..8150fbc6a1f2 100644
--- a/goofcord.sh
+++ b/goofcord.sh
@@ -1,9 +1,9 @@
#!/bin/bash
-_ELECTRON=/usr/bin/electron26
+_ELECTRON=/usr/bin/electron27
APPDIR="/usr/lib/goofcord"
export PATH="${APPDIR}:${PATH}"
-export LD_LIBRARY_PATH="${APPDIR}/lib":"${LD_LIBRARY_PATH}"
-_ASAR="${APPDIR}/resources/app.asar"
+#export LD_LIBRARY_PATH="${APPDIR}/lib":"${LD_LIBRARY_PATH}"
+_ASAR="${APPDIR}/app.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
exec ${_ELECTRON} ${_ASAR} "$@"
else