summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAUR Updater2016-08-09 14:48:01 -0400
committerRohit Agrawal2016-08-09 14:48:01 -0400
commit8251af0db96d4c591f0add4310cd7ae7f8b6b278 (patch)
tree40768ed5c296daa78dca08d6591fe6ef6e809125
parenteb0cca3b9f6d3b7a4429cd0410e3849baeb61fa0 (diff)
downloadaur-8251af0db96d4c591f0add4310cd7ae7f8b6b278.tar.gz
Update to 1.9.40.
* Also use sha1sums since these are provided on the website. * goapp symlink is added to /usr/bin * appserver command removed due to conflicts with other appengine packages.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3b1152f967a..4a98edf39444 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = google-appengine-go
pkgdesc = Google App Engine SDK for Go
- pkgver = 1.9.36
+ pkgver = 1.9.40
pkgrel = 1
url = http://code.google.com/appengine/downloads.html#Google_App_Engine_SDK_for_Go
arch = x86_64
@@ -10,13 +10,13 @@ pkgbase = google-appengine-go
depends = python2
optdepends = mysql-python: MySQL support for Python 2
optdepends = python2-imaging: Image processing capabilities for Python
- noextract = go_appengine_sdk_linux_amd64-1.9.36.zip
+ noextract = go_appengine_sdk_linux_amd64-1.9.40.zip
options = !strip
options = staticlibs
- source_x86_64 = https://commondatastorage.googleapis.com/appengine-sdks/featured/go_appengine_sdk_linux_amd64-1.9.36.zip
- md5sums_x86_64 = d316659079bd5236a29fa350c1e60874
- source_i686 = https://commondatastorage.googleapis.com/appengine-sdks/featured/go_appengine_sdk_linux_386-1.9.36.zip
- md5sums_i686 = bd8ac87ba881306d0fc3eaa85d132e02
+ source_x86_64 = https://commondatastorage.googleapis.com/appengine-sdks/featured/go_appengine_sdk_linux_amd64-1.9.40.zip
+ sha1sums_x86_64 = ae37cf701705e6d0a2d3d5c3c1e13da7c63b5cdc
+ source_i686 = https://commondatastorage.googleapis.com/appengine-sdks/featured/go_appengine_sdk_linux_386-1.9.40.zip
+ sha1sums_i686 = 4b74b95e331e80e31d2ab946050054c4baf5eccc
pkgname = google-appengine-go
diff --git a/PKGBUILD b/PKGBUILD
index 80f91963da4e..86a7d33ae411 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Max <fuzymonkey@gmail.com>
pkgname=google-appengine-go
-pkgver=1.9.36
+pkgver=1.9.40
pkgrel=1
pkgdesc='Google App Engine SDK for Go'
arch=('x86_64' 'i686')
@@ -17,8 +17,8 @@ optdepends=('mysql-python: MySQL support for Python 2'
'python2-imaging: Image processing capabilities for Python')
source_i686=("https://commondatastorage.googleapis.com/appengine-sdks/featured/go_appengine_sdk_linux_386-$pkgver.zip")
source_x86_64=("https://commondatastorage.googleapis.com/appengine-sdks/featured/go_appengine_sdk_linux_amd64-$pkgver.zip")
-md5sums_x86_64=('d316659079bd5236a29fa350c1e60874')
-md5sums_i686=('bd8ac87ba881306d0fc3eaa85d132e02')
+sha1sums_x86_64=('ae37cf701705e6d0a2d3d5c3c1e13da7c63b5cdc')
+sha1sums_i686=('4b74b95e331e80e31d2ab946050054c4baf5eccc')
# Get the name of the zip file
_source=$(echo source_$CARCH)
noextract=("$(basename ${!_source})")
@@ -40,11 +40,6 @@ build() {
msg2 "Generating wrapper script for $f named `basename $f .py`-go"
echo -e "#!/bin/sh\npython2 /opt/google-appengine-go/$f \$*" \
> "$srcdir/`basename $f .py`-go"
- if [[ $f == dev_appserver.py ]]; then
- msg2 "Creating a wrapper script for $f named appserver"
- echo -e "#!/bin/sh\npython2 /opt/google-appengine-go/$f \$*" \
- > "$srcdir/appserver"
- fi
# Modifying script to use Python 2
sed -i '0,/on/s//on2/' $f
done
@@ -70,9 +65,9 @@ package() {
cp -r "$pkgdir/opt/$pkgname/google" "$pkgdir/usr/lib/python2.7/site-packages/google"
install -d "$pkgdir/usr/bin"
- install -Dm755 "$srcdir/appserver" "$pkgdir/usr/bin/appserver"
install -Dm755 $srcdir/*-go "$pkgdir/usr/bin/"
install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ ln -s "/opt/$pkgname/goapp" "$pkgdir/usr/bin/goapp"
msg2 'Cleaning up deprecated files...'
rm -r "$pkgdir/opt/$pkgname/tools"