summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLars Hagström2016-01-27 15:20:59 +0100
committerLars Hagström2016-01-27 15:20:59 +0100
commite4e51ee9d28ac4d0258d639779ac9698ca8913fe (patch)
treeef0a6683b762a8f1acb8956a62a8f9e208e0c434
downloadaur-e4e51ee9d28ac4d0258d639779ac9698ca8913fe.tar.gz
Create new package since breakpad has migrated to git from svn
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD43
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cc01b20bbcc4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = google-breakpad-git
+ pkgdesc = An open-source multi-platform crash reporting system
+ pkgver = r1430.258591e
+ pkgrel = 1
+ url = http://code.google.com/p/google-breakpad/
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = BSD
+ makedepends = git
+ makedepends = depot-tools-git
+ depends = gcc-libs
+ conflicts = google-breakpad-svn
+ options = staticlibs
+ options = !strip
+
+pkgname = google-breakpad-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b0529b6a6294
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Lars Hagström <lars@foldspace.nu>
+# Contributor: Nephyrin Zey <nephyrin@doublezen.net>
+# Contributor: John Schoenick <john@pointysoftware.net>
+# Contributor: Geoffrey Teale <tealeg@googlemail.com>
+pkgname=google-breakpad-git
+pkgver=r1430.258591e
+pkgrel=1
+pkgdesc="An open-source multi-platform crash reporting system"
+arch=('i686' 'x86_64' 'armv7h')
+url="http://code.google.com/p/google-breakpad/"
+license=('BSD')
+makedepends=('git' 'depot-tools-git')
+depends=('gcc-libs')
+options=('staticlibs' '!strip')
+conflicts=('google-breakpad-svn')
+
+prepare() {
+ msg2 "Source download is performed in pkgver. See https://bugs.archlinux.org/task/42433"
+}
+
+pkgver() {
+ mkdir "$srcdir/${pkgname}"
+ cd "$srcdir/${pkgname}"
+ /opt/depot-tools-git/fetch breakpad > /dev/null
+
+ cd "$srcdir/${pkgname}/src"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname}/src"
+
+ msg2 "Configuring"
+ ./configure --prefix=/usr
+ msg2 "Building"
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname}/src"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+}