summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorml2021-09-03 03:07:38 +0200
committerml2021-09-03 03:07:38 +0200
commit3810883dc08fade8cb005b564fb969a228011e7c (patch)
tree16660fe2238f816b72feef54b811196161cf93a8
parentff98f756e3e2fb6712e39b1874df88d69bb4eb34 (diff)
downloadaur-3810883dc08fade8cb005b564fb969a228011e7c.tar.gz
updpkg: google-chat-linux 5.14.15+1-1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD8
-rw-r--r--sandbox.patch8
3 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bcd76870e837..fa104d7f8063 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = google-chat-linux
pkgdesc = Unofficial electron-based desktop client for Google Chat, electron not included
- pkgver = 5.12.14+2
+ pkgver = 5.14.15+1
pkgrel = 1
url = https://github.com/squalou/google-chat-linux
arch = any
@@ -9,13 +9,14 @@ pkgbase = google-chat-linux
makedepends = npm
makedepends = nodejs-lts-fermium
depends = electron
- source = https://github.com/squalou/google-chat-linux/archive/5.12.14-2/google-chat-linux-5.12.14-2.tar.gz
+ depends = xdg-desktop-portal-impl
+ source = https://github.com/squalou/google-chat-linux/archive/5.14.15-1/google-chat-linux-5.14.15-1.tar.gz
source = google-chat-linux.sh
source = google-chat-linux.desktop
source = sandbox.patch
- sha256sums = 4464725b39f511f2cdf321b5e1e68a25cf0ae02755ae43f96632f89d169ed6e4
+ sha256sums = 89d5ec2cac2afb9003f47bbbdb722f56c2671104912998e392d51fd36ddbc2cb
sha256sums = 5a458e5d7193784383ceda44faf8852410296f310acb5495d53c16bd0ea50059
sha256sums = c7fdfa74422ce7900563fd1a0f5d76c4d4cd6d153ca3b28ab5a8912a33cba9c7
- sha256sums = e4b63ca04f05b03de70fd7440981646ae7eb778fa749fd8ac26dd545833b0a43
+ sha256sums = 3f6513ded0c0da0d1b3ccd3fa08537cdd36a7f0281b66ec1021006565732b9c3
pkgname = google-chat-linux
diff --git a/PKGBUILD b/PKGBUILD
index 5659eefab4b9..fed26e3f2e22 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
# Maintainer: ml <>
pkgname=google-chat-linux
-_pkgver='5.12.14-2'
+_pkgver='5.14.15-1'
pkgver=${_pkgver/-/+}
pkgrel=1
pkgdesc='Unofficial electron-based desktop client for Google Chat, electron not included'
arch=('any')
url='https://github.com/squalou/google-chat-linux'
license=('custom:UNKNOWN')
-depends=('electron')
+depends=('electron' 'xdg-desktop-portal-impl')
makedepends=('jq' 'npm' 'nodejs-lts-fermium')
source=("$url/archive/$_pkgver/$pkgname-$_pkgver.tar.gz"
google-chat-linux.sh
google-chat-linux.desktop
sandbox.patch)
-sha256sums=('4464725b39f511f2cdf321b5e1e68a25cf0ae02755ae43f96632f89d169ed6e4'
+sha256sums=('89d5ec2cac2afb9003f47bbbdb722f56c2671104912998e392d51fd36ddbc2cb'
'5a458e5d7193784383ceda44faf8852410296f310acb5495d53c16bd0ea50059'
'c7fdfa74422ce7900563fd1a0f5d76c4d4cd6d153ca3b28ab5a8912a33cba9c7'
- 'e4b63ca04f05b03de70fd7440981646ae7eb778fa749fd8ac26dd545833b0a43')
+ '3f6513ded0c0da0d1b3ccd3fa08537cdd36a7f0281b66ec1021006565732b9c3')
_patch_package_json() {
diff --git a/sandbox.patch b/sandbox.patch
index fe784b40d2f0..332e793a8b45 100644
--- a/sandbox.patch
+++ b/sandbox.patch
@@ -1,12 +1,12 @@
diff -ura package.orig/src/index.js package.new/src/index.js
---- package.orig/src/index.js 2021-01-29 14:08:30.000000000 +0100
-+++ package.new/src/index.js 2021-02-16 03:27:41.880131306 +0100
+--- package.orig/src/index.js 2021-09-03 03:05:58.844183250 +0200
++++ package.new/src/index.js 2021-09-03 03:06:12.220938939 +0200
@@ -7,8 +7,6 @@
const applicationVersion = require('./../package.json').version;
let mainWindow, systemTrayIcon, config, contextMenu;
-process.env.NODE_OPTIONS="--no-force-async-hooks-checks";
-process.env.ELECTRON_DISABLE_SANDBOX=true;
+ process.env.GTK_USE_PORTAL=1;
- process.title = 'Google Chat Linux (Unofficial)';
- console.log(process.title + ' - v' + applicationVersion);
+ process.title = 'Google Chat Linux';