summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDet2015-08-26 20:36:59 +0300
committerDet2015-08-26 20:36:59 +0300
commita724135332bfebacfe097cb04cdcc47d2235f13f (patch)
treee0cd036ead30ec1c41b5c71815b722c32e02d6ae
parent807aaf86b0fd993e060a3d409b391bb473bbbc32 (diff)
downloadaur-a724135332bfebacfe097cb04cdcc47d2235f13f.tar.gz
Support ~/.config/chrome-flags.conf
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
-rw-r--r--google-chrome-stable9
-rw-r--r--google-chrome.install2
4 files changed, 19 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d683bca8cee..456c1787b88d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -32,7 +32,9 @@ pkgbase = google-chrome
provides = pepper-flash
options = !emptydirs
options = !strip
+ source = google-chrome-stable
source = eula_text.html
+ md5sums = 9c9bd494c7cc5c98feff767be140a853
md5sums = b7e752f549b215ac77f284b6486794b6
source_i686 = google-chrome-stable_44.0.2403.157_i386.deb::https://dl.google.com/linux/direct/google-chrome-stable_current_i386.deb
md5sums_i686 = cb57612d3c33503a3306489b222bdbc5
diff --git a/PKGBUILD b/PKGBUILD
index 9298c8e7bd20..dab4a7165f4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,10 +20,12 @@ provides=('google-chrome' 'pepper-flash')
options=('!emptydirs' '!strip')
install=$pkgname.install
_channel=stable
-source=('eula_text.html')
+source=('google-chrome-stable'
+ 'eula_text.html')
source_i686=("google-chrome-${_channel}_${pkgver}_i386.deb::https://dl.google.com/linux/direct/google-chrome-${_channel}_current_i386.deb")
source_x86_64=("google-chrome-${_channel}_${pkgver}_amd64.deb::https://dl.google.com/linux/direct/google-chrome-${_channel}_current_amd64.deb")
-md5sums=('b7e752f549b215ac77f284b6486794b6')
+md5sums=('9c9bd494c7cc5c98feff767be140a853'
+ 'b7e752f549b215ac77f284b6486794b6')
md5sums_i686=('cb57612d3c33503a3306489b222bdbc5')
md5sums_x86_64=('24097e63c43976e9f9304edd5bcd4ac0')
@@ -32,6 +34,9 @@ package() {
bsdtar -xf data.tar.xz -C "$pkgdir/"
msg2 "Moving stuff in place..."
+ # Launcher
+ install -m755 google-chrome-stable "$pkgdir"/usr/bin/
+
# Icons
for i in 16x16 22x22 24x24 32x32 48x48 64x64 128x128 256x256; do
install -Dm644 "$pkgdir"/opt/google/chrome/product_logo_${i/x*}.png \
diff --git a/google-chrome-stable b/google-chrome-stable
new file mode 100644
index 000000000000..b3b1e7729d0e
--- /dev/null
+++ b/google-chrome-stable
@@ -0,0 +1,9 @@
+#!/bin/bash
+
+# Allow users to override command-line options
+if [[ -f ~/.config/chrome-flags.conf ]]; then
+ CHROME_USER_FLAGS="$(cat ~/.config/chrome-flags.conf)"
+fi
+
+# Launch
+exec /opt/google/chrome/google-chrome $CHROME_USER_FLAGS $@ \ No newline at end of file
diff --git a/google-chrome.install b/google-chrome.install
index 585bff065086..0ed628bc150f 100644
--- a/google-chrome.install
+++ b/google-chrome.install
@@ -22,7 +22,7 @@ _update() {
post_install() {
_update
-
+ note "Custom flags should be put directly in: ~/.config/chrome-flags.conf"
note "The launcher is called: 'google-chrome-stable'"
}