summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShulhan2022-07-14 00:33:31 +0700
committerShulhan2022-07-14 00:33:31 +0700
commit2770941a0bdf96b3c71bd9817c8dc10801bc6784 (patch)
tree728b7d5852781c4d319ff8a8a5827a12f813bc7c
parent7e34076620d72f28f5fddc7267c7cb42471d453b (diff)
downloadaur-2770941a0bdf96b3c71bd9817c8dc10801bc6784.tar.gz
all: remove the patch on setting service loglevel
Since the issue regarding this patch [1] has been fixed, we did not need it anymore. [1] https://github.com/GoogleCloudPlatform/ops-agent/issues/249#issuecomment-1075184604
-rw-r--r--.SRCINFO4
-rw-r--r--0001-apps-hostmetrics.patch28
-rw-r--r--PKGBUILD5
3 files changed, 2 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af0cd4562762..236802088220 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = google-cloud-ops-agent-git
pkgdesc = Ops Agents that are part of the Google Cloud Operations product suite (specifically Cloud Logging and Cloud Monitoring)
- pkgver = 2.18.1.r7.g34192798
+ pkgver = 2.18.1.r8.gad67eb23
pkgrel = 1
url = https://github.com/GoogleCloudPlatform/ops-agent
arch = x86_64
@@ -21,12 +21,10 @@ pkgbase = google-cloud-ops-agent-git
source = fluent-bit::git+https://github.com/fluent/fluent-bit.git
source = opentelemetry-operations-collector::git+https://github.com/GoogleCloudPlatform/opentelemetry-operations-collector.git
source = opentelemetry-java-contrib::git+https://github.com/open-telemetry/opentelemetry-java-contrib.git
- source = 0001-apps-hostmetrics.patch
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
- md5sums = 9a4dfd7fe6298c12c46ca50d7f473094
pkgname = google-cloud-ops-agent-git
diff --git a/0001-apps-hostmetrics.patch b/0001-apps-hostmetrics.patch
deleted file mode 100644
index 1414457f489e..000000000000
--- a/0001-apps-hostmetrics.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-diff --git a/confgenerator/confgenerator.go b/confgenerator/confgenerator.go
-index 280bce24..f8cf09ee 100644
---- a/confgenerator/confgenerator.go
-+++ b/confgenerator/confgenerator.go
-@@ -57,7 +57,7 @@ func (uc *UnifiedConfig) GenerateOtelConfig(hostInfo *host.InfoStat) (string, er
- }.LoggingSubmodulePipeline()
-
- if uc.Metrics.Service.LogLevel == "" {
-- uc.Metrics.Service.LogLevel = "info"
-+ uc.Metrics.Service.LogLevel = "error"
- }
- otelConfig, err := otel.ModularConfig{
- LogLevel: uc.Metrics.Service.LogLevel,
-@@ -137,7 +137,7 @@ func (uc *UnifiedConfig) GenerateFluentBitConfigs(logsDir string, stateDir strin
- func (l *Logging) generateFluentbitComponents(userAgent string, hostInfo *host.InfoStat) ([]fluentbit.Component, error) {
- var out []fluentbit.Component
- if l.Service.LogLevel == "" {
-- l.Service.LogLevel = "info"
-+ l.Service.LogLevel = "error"
- }
- service := fluentbit.Service{LogLevel: l.Service.LogLevel}
- out = append(out, service.Component())
-diff --git a/submodules/fluent-bit b/submodules/fluent-bit
---- a/submodules/fluent-bit
-+++ b/submodules/fluent-bit
-@@ -1 +1 @@
--Subproject commit 9c2868fc841e1f0d9e0fd96a4bd8da164741906c
-+Subproject commit 9c2868fc841e1f0d9e0fd96a4bd8da164741906c-dirty
diff --git a/PKGBUILD b/PKGBUILD
index 289cc124d5fe..ac79f74bfa1f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: shulhan <ms@kilabit.info>
pkgname=google-cloud-ops-agent-git
-pkgver=2.18.1.r7.g34192798
+pkgver=2.18.1.r8.gad67eb23
pkgrel=1
pkgdesc="Ops Agents that are part of the Google Cloud Operations product suite (specifically Cloud Logging and Cloud Monitoring)"
@@ -36,7 +36,6 @@ source=(
"fluent-bit::git+https://github.com/fluent/fluent-bit.git"
"opentelemetry-operations-collector::git+https://github.com/GoogleCloudPlatform/opentelemetry-operations-collector.git"
"opentelemetry-java-contrib::git+https://github.com/open-telemetry/opentelemetry-java-contrib.git"
- "0001-apps-hostmetrics.patch"
)
md5sums=(
'SKIP'
@@ -44,7 +43,6 @@ md5sums=(
'SKIP'
'SKIP'
'SKIP'
- '9a4dfd7fe6298c12c46ca50d7f473094'
)
pkgver() {
@@ -64,7 +62,6 @@ prepare() {
git config submodule."submodules/opentelemetry-java-contrib".url \
"${srcdir}/opentelemetry-java-contrib"
git submodule update
- git apply "${srcdir}/0001-apps-hostmetrics.patch"
rm -rf ${srcdir}/google-cloud-ops-agent-git/submodules/opentelemetry-java-contrib/META-INF
}