summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShulhan2022-04-10 20:03:57 +0700
committerShulhan2022-04-10 20:04:42 +0700
commit780e7477cce6cfe4ed84b69dfffee830ed0dfd0b (patch)
tree14745822f5d9516946e1f1d547ea6ff1c8b32349
parenta57f3fc30dc1f8c933f39d2c37792fa03d8c3ab9 (diff)
downloadaur-780e7477cce6cfe4ed84b69dfffee830ed0dfd0b.tar.gz
all: update to release 2.13.0
This release update the patch format using "git diff".
-rw-r--r--.SRCINFO6
-rw-r--r--0001-apps-hostmetrics.patch31
-rw-r--r--PKGBUILD6
3 files changed, 18 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 804c5dd70246..cc52966d5cdf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = google-cloud-ops-agent-git
pkgdesc = Ops Agents that are part of the Google Cloud Operations product suite (specifically Cloud Logging and Cloud Monitoring)
- pkgver = 2.7.0.r7.g43187fc
- pkgrel = 2
+ pkgver = 2.13.0.r3.gec157cd8
+ pkgrel = 1
url = https://github.com/GoogleCloudPlatform/ops-agent
arch = x86_64
license = Apache License 2.0
@@ -22,6 +22,6 @@ pkgbase = google-cloud-ops-agent-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
- md5sums = a5cbb09890214d1c14a2cf33267808c5
+ md5sums = 9a4dfd7fe6298c12c46ca50d7f473094
pkgname = google-cloud-ops-agent-git
diff --git a/0001-apps-hostmetrics.patch b/0001-apps-hostmetrics.patch
index 8a5a8a807d60..1414457f489e 100644
--- a/0001-apps-hostmetrics.patch
+++ b/0001-apps-hostmetrics.patch
@@ -1,22 +1,9 @@
-diff --git a/apps/hostmetrics.go b/apps/hostmetrics.go
-index 84bdc49..14a77f7 100644
---- a/apps/hostmetrics.go
-+++ b/apps/hostmetrics.go
-@@ -43,8 +43,6 @@ func (r MetricsReceiverHostmetrics) Pipelines() []otel.Pipeline {
- "filesystem": struct{}{},
- "network": struct{}{},
- "paging": struct{}{},
-- "process": struct{}{},
-- "processes": struct{}{},
- },
- },
- },
diff --git a/confgenerator/confgenerator.go b/confgenerator/confgenerator.go
-index 1916bcd..a8443ec 100644
+index 280bce24..f8cf09ee 100644
--- a/confgenerator/confgenerator.go
+++ b/confgenerator/confgenerator.go
-@@ -47,7 +47,7 @@ func (uc *UnifiedConfig) GenerateOtelConfig(hostInfo *host.InfoStat) (string, er
- }.Pipeline()
+@@ -57,7 +57,7 @@ func (uc *UnifiedConfig) GenerateOtelConfig(hostInfo *host.InfoStat) (string, er
+ }.LoggingSubmodulePipeline()
if uc.Metrics.Service.LogLevel == "" {
- uc.Metrics.Service.LogLevel = "info"
@@ -24,12 +11,18 @@ index 1916bcd..a8443ec 100644
}
otelConfig, err := otel.ModularConfig{
LogLevel: uc.Metrics.Service.LogLevel,
-@@ -126,7 +126,7 @@ func (uc *UnifiedConfig) GenerateFluentBitConfigs(logsDir string, stateDir strin
+@@ -137,7 +137,7 @@ func (uc *UnifiedConfig) GenerateFluentBitConfigs(logsDir string, stateDir strin
func (l *Logging) generateFluentbitComponents(userAgent string, hostInfo *host.InfoStat) ([]fluentbit.Component, error) {
var out []fluentbit.Component
if l.Service.LogLevel == "" {
- l.Service.LogLevel = "info"
+ l.Service.LogLevel = "error"
}
- out = append(out, fluentbit.Service{LogLevel: l.Service.LogLevel}.Component())
-
+ service := fluentbit.Service{LogLevel: l.Service.LogLevel}
+ out = append(out, service.Component())
+diff --git a/submodules/fluent-bit b/submodules/fluent-bit
+--- a/submodules/fluent-bit
++++ b/submodules/fluent-bit
+@@ -1 +1 @@
+-Subproject commit 9c2868fc841e1f0d9e0fd96a4bd8da164741906c
++Subproject commit 9c2868fc841e1f0d9e0fd96a4bd8da164741906c-dirty
diff --git a/PKGBUILD b/PKGBUILD
index 0b8f9dbed355..ec2d164a6564 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: shulhan <ms@kilabit.info>
pkgname=google-cloud-ops-agent-git
-pkgver=2.7.0.r7.g43187fc
-pkgrel=2
+pkgver=2.13.0.r3.gec157cd8
+pkgrel=1
pkgdesc="Ops Agents that are part of the Google Cloud Operations product suite (specifically Cloud Logging and Cloud Monitoring)"
arch=(x86_64)
@@ -38,7 +38,7 @@ md5sums=(
'SKIP'
'SKIP'
'SKIP'
- 'aa21cd77ff9aba8ba7b8583c97e71c8f'
+ '9a4dfd7fe6298c12c46ca50d7f473094'
)
pkgver() {