summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShulhan2022-12-13 23:15:05 +0700
committerShulhan2022-12-13 23:18:35 +0700
commita82178cdd43d4d98480400abdd57e74fab2795ce (patch)
tree43f3a3e5814c178c69a9db38cffb2cebf57e6284
parent2770941a0bdf96b3c71bd9817c8dc10801bc6784 (diff)
downloadaur-a82178cdd43d4d98480400abdd57e74fab2795ce.tar.gz
all: fix build due to git CVE-2022-39253
When building with git v2.38.1 or latest version, the build will fail with fatal: transport 'file' not allowed This is due to security issue in git submodule [1]. While at it, update the version to the latest one. [1] https://lore.kernel.org/lkml/xmqq4jw1uku5.fsf@gitster.g/
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 236802088220..036163e1dd46 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = google-cloud-ops-agent-git
pkgdesc = Ops Agents that are part of the Google Cloud Operations product suite (specifically Cloud Logging and Cloud Monitoring)
- pkgver = 2.18.1.r8.gad67eb23
+ pkgver = 2.23.0.r33.gdeaa7dec7
pkgrel = 1
url = https://github.com/GoogleCloudPlatform/ops-agent
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index ac79f74bfa1f..b2782245df67 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: shulhan <ms@kilabit.info>
pkgname=google-cloud-ops-agent-git
-pkgver=2.18.1.r8.gad67eb23
+pkgver=2.23.0.r33.gdeaa7dec7
pkgrel=1
pkgdesc="Ops Agents that are part of the Google Cloud Operations product suite (specifically Cloud Logging and Cloud Monitoring)"
@@ -52,7 +52,7 @@ pkgver() {
prepare() {
cd "${pkgname}"
- git submodule init
+ git -c protocol.file.allow=always submodule init
git config submodule."submodules/collectd".url \
"${srcdir}/collectd"
git config submodule."submodules/fluent-bit".url \
@@ -61,7 +61,7 @@ prepare() {
"${srcdir}/opentelemetry-operations-collector"
git config submodule."submodules/opentelemetry-java-contrib".url \
"${srcdir}/opentelemetry-java-contrib"
- git submodule update
+ git -c protocol.file.allow=always submodule update
rm -rf ${srcdir}/google-cloud-ops-agent-git/submodules/opentelemetry-java-contrib/META-INF
}