summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShulhan2023-07-15 15:10:33 +0700
committerShulhan2023-07-15 15:10:33 +0700
commite0528f174342435f009cc8a17b79578fb598b2e1 (patch)
tree483390dcf5275ed8dbf5d7be1b47b05e9d64ea92
parent1d88da4acbf721ab319261e84ac27985a5812770 (diff)
downloadaur-e0528f174342435f009cc8a17b79578fb598b2e1.tar.gz
all: update make tasks for chrootpkg and patch
In the chrootpkg task, in case the _build/root already exist, the pacman sync is not updated, so we need to update the chroot system (root and $USER) to latest first before running makechrootpkg. In the patch task, generate integrity checksum without extracting the source and building the package.
-rw-r--r--Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index 13fe8fe4320f..081976f7b46c 100644
--- a/Makefile
+++ b/Makefile
@@ -8,25 +8,30 @@ check:
## Build the package using devtools.
##
-## We bind the host go, go-build cache, and .gradle cache to the chroot/build
-## to minimize re-downloading Go and Java dependencies on the next rebuild.
+## We bind the host go, go-build cache, and .gradle cache to the
+## chroot/build to minimize re-downloading Go and Java dependencies on the
+## next rebuild.
chrootpkg:
mkdir -p $$HOME/go
mkdir -p $$HOME/.cache/go-build
mkdir -p $$HOME/.gradle
mkdir -p _build
mkarchroot _build/root base-devel systemd || exit 0
+ arch-nspawn -c /var/cache/pacman/pkg _build/root \
+ pacman -Syu --noconfirm --color=never
+ arch-nspawn -c /var/cache/pacman/pkg _build/$$(whoami) \
+ pacman -Syu --noconfirm --color=never
makechrootpkg \
- -d /tmp \
- -d $$HOME/go:/build/go \
-d $$HOME/.cache/go-build:/build/.cache/go-build \
-d $$HOME/.gradle:/build/.gradle \
+ -d $$HOME/go:/build/go \
+ -d /tmp \
-r _build \
- -- --nocolor
+ -- --noconfirm --needed --nocolor
patch:
- git -C src/google-cloud-ops-agent-git diff > 0001-build-sh.patch && \
- makepkg -g
+ git -C src/google-cloud-ops-agent-git diff > 0001-build-sh.patch
+ makepkg --noextract --nobuild --geninteg
release:
makepkg --printsrcinfo > .SRCINFO