summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Denhartog2021-12-15 06:38:10 -0700
committerBenjamin Denhartog2021-12-15 06:49:11 -0700
commit048d96070a696056b91e55168b956445140d16a8 (patch)
tree583f887ca820b910af81844af416824de095d961
parenta1c4ab63dafcc65317f2fb8e1cfcdc7dd079e781 (diff)
downloadaur-048d96070a696056b91e55168b956445140d16a8.tar.gz
revert "feat: remove extraneous (and erroneous) comment regarding collections.abc patch"
This reverts commit 72f99ab9bc62a4eddfa953d8b74a4918a56faa2c. Closes: sudoforge/pkgbuilds#51 Change-Id: I16fa251fbc2b4392b421de9918023d3ae243a21c GitOrigin-RevId: 1b0e9236361fda90c60269456ef1be9f7f9119e2
-rw-r--r--.SRCINFO4
-rw-r--r--0004-collections-abc.patch5
-rw-r--r--PKGBUILD4
3 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96acfbb9c84e..897a35dcba82 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = google-cloud-sdk
pkgdesc = A set of command-line tools for the Google Cloud Platform. Includes gcloud (with beta and alpha commands), gsutil, and bq.
pkgver = 367.0.0
- pkgrel = 3
+ pkgrel = 4
url = https://cloud.google.com/sdk/
arch = x86_64
license = Apache
@@ -21,6 +21,6 @@ pkgbase = google-cloud-sdk
sha256sums = 62ec7f56e09168d375823e9e99fcdcfbf40b0fffdd75f35cf91122c5902c82e9
sha256sums = ff6065ce2e54ac654605bd5fe554313b1d0def2c31ce56ff39429098dd1e39fe
sha256sums = 4694f5191ceea7cf8076861ce5790ba9e809023da278b0f6ed862b9611e5aa93
- sha256sums = 18a50289f2970390a77458380bd52a6102d9f7fd2a58d43faba8fbde1a1ec3ce
+ sha256sums = 65c9f15945903bd0e1f522c31520db6d1346687c0d2bec1f4d2a13a778d6dea9
pkgname = google-cloud-sdk
diff --git a/0004-collections-abc.patch b/0004-collections-abc.patch
index 7303871d3f25..703611111aca 100644
--- a/0004-collections-abc.patch
+++ b/0004-collections-abc.patch
@@ -18,6 +18,7 @@ diff -urN --color a/lib/googlecloudsdk/api_lib/run/traffic.py b/lib/googleclouds
from googlecloudsdk.core import exceptions
+try:
++ # Python 3.3 and above.
+ collections_abc = collections.abc
+except AttributeError:
+ collections_abc = collections
@@ -43,6 +44,7 @@ diff -urN --color a/lib/third_party/dns/namedict.py b/lib/third_party/dns/namedi
-class NameDict(collections.MutableMapping):
+try:
++ # Python 3.3 and above.
+ collections_abc = collections.abc
+except AttributeError:
+ collections_abc = collections
@@ -60,6 +62,7 @@ diff -urN --color a/lib/third_party/frozendict/__init__.py b/lib/third_party/fro
import sys
+try:
++ # Python 3.3 and above.
+ collections_abc = collections.abc
+except AttributeError:
+ collections_abc = collections
@@ -108,6 +111,7 @@ diff -urN --color a/lib/third_party/ml_sdk/cloud/ml/prediction/prediction_utils.
from tensorflow.python.framework import dtypes # pylint: disable=g-direct-tensorflow-import
+try:
++ # Python 3.3 and above.
+ collections_abc = collections.abc
+except AttributeError:
+ collections_abc = collections
@@ -196,6 +200,7 @@ diff -urN --color a/platform/gsutil/gslib/vendored/boto/boto/mws/connection.py b
from boto.compat import filter, map, six, encodebytes
+try:
++ # Python 3.3 and above.
+ collections_abc = collections.abc
+except AttributeError:
+ collections_abc = collections
diff --git a/PKGBUILD b/PKGBUILD
index 8ea3da760d8e..a1a14cc00793 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
pkgname="google-cloud-sdk"
pkgver=367.0.0
-pkgrel=3
+pkgrel=4
pkgdesc="A set of command-line tools for the Google Cloud Platform. Includes gcloud (with beta and alpha commands), gsutil, and bq."
url="https://cloud.google.com/sdk/"
license=("Apache")
@@ -34,7 +34,7 @@ sha256sums=('1d529c381e012f33f09cd436ca6e1d49ea83ec18fef5552ad00885210f024026'
'62ec7f56e09168d375823e9e99fcdcfbf40b0fffdd75f35cf91122c5902c82e9'
'ff6065ce2e54ac654605bd5fe554313b1d0def2c31ce56ff39429098dd1e39fe'
'4694f5191ceea7cf8076861ce5790ba9e809023da278b0f6ed862b9611e5aa93'
- '18a50289f2970390a77458380bd52a6102d9f7fd2a58d43faba8fbde1a1ec3ce')
+ '65c9f15945903bd0e1f522c31520db6d1346687c0d2bec1f4d2a13a778d6dea9')
prepare() {
cd "${srcdir}/${pkgname}"