summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Denhartog2020-01-23 19:50:11 -0800
committerBenjamin Denhartog2020-01-23 20:41:46 -0800
commit2c3b78123668f8f32b5a64181550eb702a5303f9 (patch)
tree5c56d9daa7bfb03ed79425ece797d096ae91d49d
parent5ab0c1c93ca87c61f7c794cc09d95e82682a76d1 (diff)
downloadaur-2c3b78123668f8f32b5a64181550eb702a5303f9.tar.gz
fix(google-cloud-sdk): add patch file to force endpointscfg.py to python2
endpointscfg.py does not currently support Python3. See `gcloud topic startup` [0] for more information. [0]: https://cloud.google.com/sdk/gcloud/reference/topic/startup
-rw-r--r--.SRCINFO4
-rw-r--r--0003-set-python2-for-endpointscfg-py.patch9
-rw-r--r--PKGBUILD6
3 files changed, 16 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43ed1dae2fc8..2bd4ad0977ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = google-cloud-sdk
pkgdesc = A set of command-line tools for the Google Cloud Platform. Includes gcloud (with beta and alpha commands), gsutil, and bq.
pkgver = 276.0.0
- pkgrel = 4
+ pkgrel = 5
url = https://cloud.google.com/sdk/
arch = x86_64
license = Apache
@@ -14,10 +14,12 @@ pkgbase = google-cloud-sdk
source = google-cloud-sdk.sh
source = 0001-fix-console-io-syntax-warning.patch
source = 0002-set-python2-for-dev-appserver-py.patch
+ source = 0003-set-python2-for-endpointscfg-py.patch
sha256sums = ad3d711e372fdcef141106d33e150aee4922a88c76484798a40b48a2fc779c3c
sha256sums = a54f88947a2593fae4aa8f65e42de4ad735583ae743735305c0f36710a794295
sha256sums = b3faeb3af2922510048d12063fa215610f12879f5cc9f8b78786c7d9f2957c70
sha256sums = 62ec7f56e09168d375823e9e99fcdcfbf40b0fffdd75f35cf91122c5902c82e9
+ sha256sums = ff6065ce2e54ac654605bd5fe554313b1d0def2c31ce56ff39429098dd1e39fe
pkgname = google-cloud-sdk
diff --git a/0003-set-python2-for-endpointscfg-py.patch b/0003-set-python2-for-endpointscfg-py.patch
new file mode 100644
index 000000000000..93e590a6a284
--- /dev/null
+++ b/0003-set-python2-for-endpointscfg-py.patch
@@ -0,0 +1,9 @@
+diff -urN --color a/bin/endpointscfg.py b/bin/endpointscfg.py
+--- a/bin/endpointscfg.py 2020-01-23 20:12:58.838993348 -0800
++++ b/bin/endpointscfg.py 2020-01-23 20:13:14.125618291 -0800
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ #
+ # Copyright 2015 Google Inc. All Rights Reserved.
+ #
diff --git a/PKGBUILD b/PKGBUILD
index d9589af040b7..4b26571249a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname="google-cloud-sdk"
pkgver=276.0.0
-pkgrel=4
+pkgrel=5
pkgdesc="A set of command-line tools for the Google Cloud Platform. Includes gcloud (with beta and alpha commands), gsutil, and bq."
url="https://cloud.google.com/sdk/"
license=("Apache")
@@ -22,11 +22,13 @@ source=(
"google-cloud-sdk.sh"
"0001-fix-console-io-syntax-warning.patch"
"0002-set-python2-for-dev-appserver-py.patch"
+ "0003-set-python2-for-endpointscfg-py.patch"
)
sha256sums=('ad3d711e372fdcef141106d33e150aee4922a88c76484798a40b48a2fc779c3c'
'a54f88947a2593fae4aa8f65e42de4ad735583ae743735305c0f36710a794295'
'b3faeb3af2922510048d12063fa215610f12879f5cc9f8b78786c7d9f2957c70'
- '62ec7f56e09168d375823e9e99fcdcfbf40b0fffdd75f35cf91122c5902c82e9')
+ '62ec7f56e09168d375823e9e99fcdcfbf40b0fffdd75f35cf91122c5902c82e9'
+ 'ff6065ce2e54ac654605bd5fe554313b1d0def2c31ce56ff39429098dd1e39fe')
prepare() {
cd "$pkgname"