summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Denhartog2019-11-05 16:38:30 -0800
committerBenjamin Denhartog2019-11-05 16:38:30 -0800
commit7294bd9d565173f7ce605d7740b5c0b854b71c90 (patch)
treed3efb566ae42c92479a43877b087ef6f6c11b818
parentdd80db6a28eae0c7b88b8cec2e30c03f3de02293 (diff)
downloadaur-7294bd9d565173f7ce605d7740b5c0b854b71c90.tar.gz
new release: google-cloud-sdk 270.0.0-2
fix erroneous dependency on python3. python2.7 is required for all gcloud utilities; however, the core `gcloud` utility has experimental support for python3. for more information, see: - https://cloud.google.com/sdk/gcloud/reference/topic/startup
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b4baea1733e..fb87a2ced6fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = google-cloud-sdk
pkgdesc = A set of command-line tools for the Google Cloud Platform. Includes gcloud (with beta and alpha commands), gsutil, and bq.
pkgver = 270.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://cloud.google.com/sdk/
arch = x86_64
license = Apache
- depends = python3
+ depends = python2
+ optdepends = python3: experimental support. see https://cloud.google.com/sdk/gcloud/reference/topic/startup
optdepends = python2-crcmod: [gsutil] verify the integrity of GCS object contents
options = !strip
options = staticlibs
diff --git a/PKGBUILD b/PKGBUILD
index 54c992c49dbd..080aac4b6ec5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,13 +8,16 @@
pkgname="google-cloud-sdk"
pkgver=270.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="A set of command-line tools for the Google Cloud Platform. Includes gcloud (with beta and alpha commands), gsutil, and bq."
url="https://cloud.google.com/sdk/"
license=("Apache")
arch=('x86_64')
-depends=('python3')
-optdepends=('python2-crcmod: [gsutil] verify the integrity of GCS object contents')
+depends=('python2')
+optdepends=(
+ "python3: experimental support. see https://cloud.google.com/sdk/gcloud/reference/topic/startup"
+ "python2-crcmod: [gsutil] verify the integrity of GCS object contents"
+)
options=('!strip' 'staticlibs')
source=(
"https://dl.google.com/dl/cloudsdk/release/downloads/for_packagers/linux/${pkgname}_${pkgver}.orig.tar.gz"