summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTroy Engel2016-10-16 09:49:14 -0500
committerTroy Engel2016-10-16 09:49:14 -0500
commitedf70e9b24eff06ff59b93bbe9410fe9a43cb513 (patch)
tree5808f110b2092d4252458a646a0ba44e700b1e74
parent24f781f2de1091fb3cd3f4f46ac1f83c88288299 (diff)
downloadaur-edf70e9b24eff06ff59b93bbe9410fe9a43cb513.tar.gz
130.0.0, GOOGLE_CLOUD_SDK_HOME, app-engine-python
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD29
-rw-r--r--profile.sh1
3 files changed, 33 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fc24b97eb8b3..8f9da168f52f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Oct 5 23:33:23 UTC 2016
+# Sun Oct 16 14:47:03 UTC 2016
pkgbase = google-cloud-sdk
- pkgdesc = Contains tools and libraries that enable you to easily create and manage resources on Google Cloud Platform
- pkgver = 129.0.0
+ pkgdesc = Tools and libraries SDK for managing resources on the Google Cloud Platform, plus kubectl and Python/PHP appengine SDK components
+ pkgver = 130.0.0
pkgrel = 1
url = https://cloud.google.com/sdk/
arch = i686
@@ -15,16 +15,23 @@ pkgbase = google-cloud-sdk
optdepends = php: for PHP version of App Engine
optdepends = python2-crcmod: verify the integrity of object contents
conflicts = kubectl-bin
+ conflicts = google-appengine-python-php
+ conflicts = google-appengine-python
+ conflicts = google-appengine-php
+ replaces = kubectl-bin
+ replaces = google-appengine-python-php
+ replaces = google-appengine-python
+ replaces = google-appengine-php
options = !strip
options = staticlibs
- source_i686 = https://dl.google.com/dl/cloudsdk/release/downloads/google-cloud-sdk-129.0.0-linux-x86.tar.gz
+ source_i686 = https://dl.google.com/dl/cloudsdk/release/downloads/google-cloud-sdk-130.0.0-linux-x86.tar.gz
source_i686 = profile.sh
- sha1sums_i686 = dd859a30d674f3a138c2823fb440346cf498d5f7
- sha1sums_i686 = 9c09e242b113e50e3f2fa05b6c6c7b0ff33b4b71
- source_x86_64 = https://dl.google.com/dl/cloudsdk/release/downloads/google-cloud-sdk-129.0.0-linux-x86_64.tar.gz
+ sha1sums_i686 = d13472b9bcd6d46198d6655ec97c1ad0cf3f3150
+ sha1sums_i686 = 770d136b9feaf36f3fd595234b0d9366b40de16c
+ source_x86_64 = https://dl.google.com/dl/cloudsdk/release/downloads/google-cloud-sdk-130.0.0-linux-x86_64.tar.gz
source_x86_64 = profile.sh
- sha1sums_x86_64 = 12b413f1dcfeaf601f70749142f06e01e32c03ad
- sha1sums_x86_64 = 9c09e242b113e50e3f2fa05b6c6c7b0ff33b4b71
+ sha1sums_x86_64 = ba5f6539cf3f8f471173a8dc5f38629758f246b5
+ sha1sums_x86_64 = 770d136b9feaf36f3fd595234b0d9366b40de16c
pkgname = google-cloud-sdk
diff --git a/PKGBUILD b/PKGBUILD
index 5ceaa87ea3c9..0081161c32bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,17 @@
# Contributor: Justin Dray <justin@dray.be>
pkgname="google-cloud-sdk"
-pkgver=129.0.0
+pkgver=130.0.0
pkgrel=1
-pkgdesc="Contains tools and libraries that enable you to easily create and manage resources on Google Cloud Platform"
+pkgdesc="Tools and libraries SDK for managing resources on the Google Cloud Platform, plus kubectl and Python/PHP appengine SDK components"
url="https://cloud.google.com/sdk/"
license=("Apache")
arch=('i686' 'x86_64')
-conflicts=('kubectl-bin')
+# replaces() only works for sysupgrade, not normal install/upgrade
+conflicts=('kubectl-bin' 'google-appengine-python-php'
+ 'google-appengine-python' 'google-appengine-php')
+replaces=('kubectl-bin' 'google-appengine-python-php'
+ 'google-appengine-python' 'google-appengine-php')
depends=('python2')
makedepends=('python2')
optdepends=('go: for Go version of App Engine'
@@ -22,14 +26,14 @@ options=('!strip' 'staticlibs')
# 64bit
source_x86_64=("https://dl.google.com/dl/cloudsdk/release/downloads/$pkgname-$pkgver-linux-x86_64.tar.gz"
"profile.sh")
-sha1sums_x86_64=('12b413f1dcfeaf601f70749142f06e01e32c03ad'
- '9c09e242b113e50e3f2fa05b6c6c7b0ff33b4b71')
+sha1sums_x86_64=('ba5f6539cf3f8f471173a8dc5f38629758f246b5'
+ '770d136b9feaf36f3fd595234b0d9366b40de16c')
# 32bit
source_i686=("https://dl.google.com/dl/cloudsdk/release/downloads/$pkgname-$pkgver-linux-x86.tar.gz"
"profile.sh")
-sha1sums_i686=('dd859a30d674f3a138c2823fb440346cf498d5f7'
- '9c09e242b113e50e3f2fa05b6c6c7b0ff33b4b71')
+sha1sums_i686=('d13472b9bcd6d46198d6655ec97c1ad0cf3f3150'
+ '770d136b9feaf36f3fd595234b0d9366b40de16c')
prepare() {
@@ -52,10 +56,13 @@ package() {
cp -r "$srcdir/$pkgname" "$pkgdir/opt"
# kubectl is not in the tarball, add it to the package bootstrap
- msg2 "Running bootstrapping script and adding kubectl"
+ # app-engine-python is actually the PHP+Python SDK widgets combined
+ # NOTE: do to how Google is using argparse we must bare word the components
+ msg2 "Running bootstrapping script and adding kubectl, app-engine-python"
python2 "$pkgdir/opt/$pkgname/bin/bootstrapping/install.py" \
--usage-reporting false --path-update false --bash-completion false \
- --rc-path="$srcdir/fake.bashrc" --additional-components="kubectl"
+ --rc-path="$srcdir/fake.bashrc" \
+ --additional-components kubectl app-engine-python
# This is the strangest design they made to backup a fresh install
msg2 "Removing unnecessary backups created by bootstrap"
@@ -85,10 +92,6 @@ package() {
mkdir -p "$pkgdir/usr/bin"
find "$pkgdir/opt/$pkgname/bin" -maxdepth 1 -type f -printf \
"/opt/$pkgname/bin/%f\n" | xargs ln -st "$pkgdir/usr/bin"
- # this conflicts with google-appengine-python
- rm -f "$pkgdir/usr/bin/dev_appserver.py"
- # this conflicts with google-appengine-python-php
- rm -f "$pkgdir/usr/bin/endpointscfg.py"
# The tarball is rather sloppy with it's file permissions
msg2 "Fixing file permissions"
diff --git a/profile.sh b/profile.sh
index ab3305075934..9713b0963854 100644
--- a/profile.sh
+++ b/profile.sh
@@ -2,3 +2,4 @@ export CLOUDSDK_ROOT_DIR=/opt/google-cloud-sdk
export CLOUDSDK_PYTHON=python2
export CLOUDSDK_PYTHON_ARGS=-S
export PATH=$CLOUDSDK_ROOT_DIR/bin:$PATH
+export GOOGLE_CLOUD_SDK_HOME=$CLOUDSDK_ROOT_DIR