summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGreg Darke2020-05-17 06:56:07 +1000
committerGreg Darke2020-05-17 07:23:52 +1000
commit84c842f771a6d4b05fc68631327eb7826fced8cd (patch)
tree553944127935602be30289da327a436c4215459a
parent50989f9160753a1672eaebc69989b5bf14e5b55b (diff)
downloadaur-84c842f771a6d4b05fc68631327eb7826fced8cd.tar.gz
Remove explicit version dependency for cloud sdk components.
If require a specific version of the google-cloud-sdk package in one of the extra components, then this will make it difficult (impossible?) to perform an in-place upgrade of these packages (since you can not upgrade the google-cloud-sdk package without breaking the existing install of the google-cloud-sdk-datastore-emulator package, and you can not build the new google-cloud-sdk-datastore-emulator package without the new google-cloud-sdk package being installed). I think the only way to do this where all of the parts have the required version would be to use a split package. But I suspect most people don't want to have to download the datastore/app engine parts. I suspect the next best thing is to just have a requirement on the correct package, and assume that people will upgrade all of them at the same time (and if they don't, they get to keep the broken pieces).
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d72a3033afe..6bc635718774 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = google-cloud-sdk-app-engine-python
pkgdesc = A google-cloud-sdk component that provides the Python runtime for AppEngine.
pkgver = 292.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://cloud.google.com/sdk/
arch = x86_64
license = Apache
- depends = google-cloud-sdk=292.0.0
+ depends = google-cloud-sdk
depends = python2
options = !strip
source = https://dl.google.com/dl/cloudsdk/release/downloads/for_packagers/linux/google-cloud-sdk-app-engine-python_292.0.0.orig.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 0f337073c4aa..784320cbcaad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
pkgname=google-cloud-sdk-app-engine-python
pkgver=292.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="A google-cloud-sdk component that provides the Python runtime for AppEngine."
url="https://cloud.google.com/sdk/"
license=("Apache")
arch=('x86_64')
options=('!strip')
depends=(
- "google-cloud-sdk=${pkgver}"
+ "google-cloud-sdk"
"python2"
)
source=(