summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGreg Darke2020-05-17 06:56:07 +1000
committerGreg Darke2020-05-17 07:23:52 +1000
commita533a9dad7df544ed3ab76bf0d56b9c588166bb1 (patch)
tree19071da5b012e8b69e152eadf304bfa091402595
parent6d5a9fb31f695e9a04d6196668ee0a9f546d998c (diff)
downloadaur-a533a9dad7df544ed3ab76bf0d56b9c588166bb1.tar.gz
Remove explicit version dependency for cloud sdk components.
If require a specific version of the google-cloud-sdk package in one of the extra components, then this will make it difficult (impossible?) to perform an in-place upgrade of these packages (since you can not upgrade the google-cloud-sdk package without breaking the existing install of the google-cloud-sdk-datastore-emulator package, and you can not build the new google-cloud-sdk-datastore-emulator package without the new google-cloud-sdk package being installed). I think the only way to do this where all of the parts have the required version would be to use a split package. But I suspect most people don't want to have to download the datastore/app engine parts. I suspect the next best thing is to just have a requirement on the correct package, and assume that people will upgrade all of them at the same time (and if they don't, they get to keep the broken pieces).
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c90c9d125df3..a0ca3b261b5b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = google-cloud-sdk-app-engine-python-extras
pkgdesc = A google-cloud-sdk component that provides extra libraries for the Python runtime for AppEngine.
pkgver = 292.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://cloud.google.com/sdk/
arch = x86_64
license = Apache
- depends = google-cloud-sdk=292.0.0
- depends = google-cloud-sdk-app-engine-python=292.0.0
+ depends = google-cloud-sdk
+ depends = google-cloud-sdk-app-engine-python
options = !strip
source = https://dl.google.com/dl/cloudsdk/release/downloads/for_packagers/linux/google-cloud-sdk-app-engine-python-extras_292.0.0.orig.tar.gz
sha256sums = 282f3aeccdb1a7d96b6f0918bcb13e9151a3330dac20a7e4b0f0dc1782959bb4
diff --git a/PKGBUILD b/PKGBUILD
index 9e0b69d8dab6..7999cec5b00d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,15 @@
pkgname=google-cloud-sdk-app-engine-python-extras
pkgver=292.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="A google-cloud-sdk component that provides extra libraries for the Python runtime for AppEngine."
url="https://cloud.google.com/sdk/"
license=("Apache")
arch=('x86_64')
options=('!strip')
depends=(
- "google-cloud-sdk=${pkgver}"
- "google-cloud-sdk-app-engine-python=${pkgver}"
+ "google-cloud-sdk"
+ "google-cloud-sdk-app-engine-python"
)
source=(
"https://dl.google.com/dl/cloudsdk/release/downloads/for_packagers/linux/${pkgname}_${pkgver}.orig.tar.gz"