summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo Lahtinen2019-10-22 23:57:40 +0300
committerLeo Lahtinen2019-10-22 23:57:40 +0300
commit33548b3ab65a993b77514871195685b3e922b78d (patch)
tree13140cf21571d2915cbc93c1f881a4072bbebf6f
downloadaur-33548b3ab65a993b77514871195685b3e922b78d.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore13
-rw-r--r--PKGBUILD36
-rw-r--r--google-docs-nativefier.desktop8
-rw-r--r--google-docs-nativefier.pngbin0 -> 11501 bytes
5 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2bddac2bd8da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = google-docs-nativefier
+ pkgdesc = Electron wrapper for the Google Docs web application
+ pkgver = 1
+ pkgrel = 1
+ url = https://docs.google.com
+ arch = x86_64
+ license = MIT
+ makedepends = nodejs
+ makedepends = nodejs-nativefier
+ makedepends = npm
+ source = google-docs-nativefier.png
+ source = google-docs-nativefier.desktop
+ sha256sums = 5231652761dce688ddd2f4b2a5b958fd5486acaa181ec239fd9d330d835b5bbb
+ sha256sums = e7a2eacb79e13849f616ad148adbd2fe570db775a2dd211ba0912292885492d6
+
+pkgname = google-docs-nativefier
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b73905529f23
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,13 @@
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..878f66ba05ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Leo_L <Leo dot Lahtinen at protonmail dot com>
+
+pkgname=google-docs-nativefier
+pkgver=1
+pkgrel=1
+pkgdesc="Electron wrapper for the Google Docs web application"
+arch=(x86_64)
+license=(MIT)
+url=https://docs.google.com
+source=($pkgname.png
+ $pkgname.desktop)
+makedepends=(nodejs nodejs-nativefier npm)
+sha256sums=('5231652761dce688ddd2f4b2a5b958fd5486acaa181ec239fd9d330d835b5bbb'
+ 'e7a2eacb79e13849f616ad148adbd2fe570db775a2dd211ba0912292885492d6')
+
+_instname=google-docs
+
+build() {
+ nativefier "https://docs.google.com/" \
+ --icon $pkgname.png \
+ --maximize \
+ --internal-urls "(accounts|docs)\.google" \
+ --name "Google Docs"
+}
+
+package() {
+ install -d "$pkgdir"/opt "$pkgdir"/usr/{bin,share/pixmaps}
+ install -Dm644 $pkgname.desktop "$pkgdir"/usr/share/applications/$_instname.desktop
+
+ cp -rL $_instname-linux-* "$pkgdir"/opt/$pkgname
+ ln -sf /opt/$pkgname/$_instname "$pkgdir"/usr/bin/$_instname
+ ln -sf /opt/$pkgname/resources/app/icon.png "$pkgdir"/usr/share/pixmaps/$_instname.png
+
+ chmod 666 "$pkgdir"/opt/$pkgname/resources/app/nativefier.json
+}
+
diff --git a/google-docs-nativefier.desktop b/google-docs-nativefier.desktop
new file mode 100644
index 000000000000..28d244655b3d
--- /dev/null
+++ b/google-docs-nativefier.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Name=Google Docs
+Comment=With Google Docs, you can write, edit, and collaborate wherever you are. For Free.
+Exec=google-docs
+Icon=/usr/share/pixmaps/google-docs.png
+Terminal=false
+Categories=Productivity;Docs;Google;Nativefier;
diff --git a/google-docs-nativefier.png b/google-docs-nativefier.png
new file mode 100644
index 000000000000..b46daa20b0c7
--- /dev/null
+++ b/google-docs-nativefier.png
Binary files differ