summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Price2019-03-03 22:36:30 -0800
committerChristopher Price2019-03-03 22:36:30 -0800
commit079dfc2b10019a1799a442addd72118fb82c8300 (patch)
treeb19004717fb4982f31b2f7cad28458798a6f2430
parenta4b363927ee1893c6b5c8c2f0b5cccb235355128 (diff)
downloadaur-079dfc2b10019a1799a442addd72118fb82c8300.tar.gz
Updated to latest release v0.7.1: Replace deprecated jbuilder references with dune
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 502cefd6268e..8f64b8e3ea81 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = google-drive-ocamlfuse
pkgdesc = FUSE-based file system backed by Google Drive, written in OCaml
- pkgver = 0.7.0
+ pkgver = 0.7.1
pkgrel = 1
url = https://astrada.github.io/google-drive-ocamlfuse/
arch = x86_64
@@ -14,8 +14,8 @@ pkgbase = google-drive-ocamlfuse
makedepends = dune
makedepends = ocaml-ounit
options = staticlibs
- source = https://github.com/astrada/google-drive-ocamlfuse/archive/v0.7.0.tar.gz
- sha256sums = 7dd831f2909b9adf071daadb5ae1cff153621457937ac22ec7be37e30e5dfc51
+ source = https://github.com/astrada/google-drive-ocamlfuse/archive/v0.7.1.tar.gz
+ sha256sums = a6fb7d538e843d3ab6e295239087a157ef12aa09a63352a6a5a82dab13556c57
pkgname = google-drive-ocamlfuse
diff --git a/PKGBUILD b/PKGBUILD
index cbe0c65b0dcb..d2d743d6bb0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Christopher Price <pricechrispy at gmail dot com>
# Contributor: Moritz Lipp <mlq@pwmt.org>
pkgname=google-drive-ocamlfuse
-pkgver=0.7.0
+pkgver=0.7.1
pkgrel=1
pkgdesc='FUSE-based file system backed by Google Drive, written in OCaml'
arch=('x86_64' 'i686')
@@ -20,17 +20,17 @@ makedepends=(
)
options=('staticlibs')
source=("https://github.com/astrada/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('7dd831f2909b9adf071daadb5ae1cff153621457937ac22ec7be37e30e5dfc51')
+sha256sums=('a6fb7d538e843d3ab6e295239087a157ef12aa09a63352a6a5a82dab13556c57')
build() {
cd "$srcdir/$pkgname-$pkgver"
- # Old method requires ocamlbuild instead of jbuilder
+ # Old method requires ocamlbuild instead of jbuilder/dune
#ocaml setup.ml -configure --prefix /usr --destdir "$pkgdir" --exec-prefix "/usr"
#ocaml setup.ml -build
- #jbuilder build --debug-backtraces --debug-dependency-path --debug-findlib --no-buffer --verbose @install
- jbuilder build @install
+ #dune build --debug-backtraces --debug-dependency-path --debug-findlib --no-buffer --verbose @install
+ dune build @install
}
#check() {
@@ -48,5 +48,5 @@ package() {
mkdir -p "$pkgdir/usr"
mkdir -p "$pkgdir/$(ocamlfind printconf destdir)"
- jbuilder install --prefix="$pkgdir/usr" --libdir="$pkgdir/$(ocamlfind printconf destdir)"
+ dune install --prefix="$pkgdir/usr" --libdir="$pkgdir/$(ocamlfind printconf destdir)"
}