summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoritz Lipp2015-06-15 20:16:40 +0200
committerMoritz Lipp2015-06-15 20:16:40 +0200
commit9c2c1c0868886c0b641033f9df58b0c51aa52ff7 (patch)
treee1e287925019347667fffdccce57186db286adc5
downloadaur-9c2c1c0868886c0b641033f9df58b0c51aa52ff7.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD31
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..39ac464f37f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = google-drive-ocamlfuse
+ pkgdesc = FUSE filesystem backed by Google Drive, written in OCaml.
+ pkgver = 0.5.15
+ pkgrel = 1
+ url = http://gdfuse.forge.ocamlcore.org/
+ arch = x86_64
+ arch = i686
+ license = MIT
+ depends = ocaml>=3.12.0
+ depends = ocaml-findlib>=1.2.7
+ depends = ocamlfuse>=2.7.1
+ depends = gapi-ocaml>=0.2.6
+ depends = ocaml-sqlite3>=1.6.1
+ options = staticlibs
+ source = https://github.com/astrada/google-drive-ocamlfuse/archive/v0.5.15.tar.gz
+ md5sums = be8b34485e82c5db1fd4c4b6f5dfeb25
+
+pkgname = google-drive-ocamlfuse
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3e4b7f3b17be
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Moritz Lipp <mlq@pwmt.org>
+pkgname=google-drive-ocamlfuse
+pkgver=0.5.15
+pkgrel=1
+pkgdesc="FUSE filesystem backed by Google Drive, written in OCaml."
+arch=('x86_64' 'i686')
+url="http://gdfuse.forge.ocamlcore.org/"
+license=('MIT')
+depends=('ocaml>=3.12.0' 'ocaml-findlib>=1.2.7' 'ocamlfuse>=2.7.1'
+'gapi-ocaml>=0.2.6' 'ocaml-sqlite3>=1.6.1')
+source=(https://github.com/astrada/$pkgname/archive/v$pkgver.tar.gz)
+md5sums=('be8b34485e82c5db1fd4c4b6f5dfeb25')
+options=('staticlibs')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ocaml setup.ml -configure --prefix /usr --destdir $pkgdir
+ ocaml setup.ml -build
+}
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ocaml setup.ml -test
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ export OCAMLFIND_DESTDIR="$pkgdir/$(ocamlfind printconf destdir)"
+
+ ocaml setup.ml -install
+}