summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDet2016-09-01 16:07:47 +0300
committerDet2016-09-01 16:07:47 +0300
commit2352c6efa37eaf3e5932e111fb7e208c12cd523c (patch)
treed0449c2f2736d10df9d0c065b57e0d4ac0e02c94
parenteb330ed7f7acb1ed43ee7cddc7c810e6ca136d76 (diff)
downloadaur-2352c6efa37eaf3e5932e111fb7e208c12cd523c.tar.gz
Remove the 64-bit .deb flag
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD47
2 files changed, 24 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 565e92c9bd2e..9ff20d856169 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,33 +8,35 @@ pkgbase = google-earth
arch = x86_64
license = custom:earth
depends = desktop-file-utils
+ depends = fontconfig
+ depends = glu
depends = hicolor-icon-theme
depends = ld-lsb>=3-5
- depends = lib32-fontconfig
- depends = lib32-glu
- depends = lib32-libgl
- depends = lib32-libsm
- depends = lib32-libxrender
- depends = lib32-mesa
+ depends = libgl
+ depends = libsm
+ depends = libxrender
+ depends = mesa
depends = shared-mime-info
depends = xdg-utils
- optdepends = lib32-catalyst-utils: For AMD Catalyst
- optdepends = lib32-nvidia-utils: For the NVIDIA driver
+ optdepends = catalyst-utils: For AMD Catalyst
+ optdepends = nvidia-utils: For the NVIDIA driver
options = !emptydirs
- source = google-earth-stable_7.1.7.2600_i386.deb::https://dl.google.com/earth/client/current/google-earth-stable_current_i386.deb
source = googleearth.sh
source = baifaao.cpp
source = Google-Terms-of-Service.html::https://www.google.com/intl/ALL/policies/terms/index.html
source = Google-Earth-Additional-Terms-of-Service.html::https://www.google.com/help/terms_maps.html
source = Legal-Notices-for-Google-Earth-and-Google-Earth-APIs.html::https://www.google.com/help/legalnotices_maps.html
source = Google-Privacy-Policy.html::https://www.google.com/intl/ALL/policies/privacy/index.html
- md5sums = cc02daa74d1b81daf44326a25460a88b
md5sums = e84f5d51ea3545c131d1794f89f6464a
md5sums = 598d579a1c3199c77850d86ba78f7b44
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ source_i686 = google-earth-stable_7.1.7.2600_i386.deb::https://dl.google.com/earth/client/current/google-earth-stable_current_i386.deb
+ md5sums_i686 = cc02daa74d1b81daf44326a25460a88b
+ source_x86_64 = google-earth-stable_7.1.7.2600_amd64.deb::https://dl.google.com/earth/client/current/google-earth-stable_current_amd64.deb
+ md5sums_x86_64 = e6356f9bb99d9019ee0a156f9331beb8
pkgname = google-earth
diff --git a/PKGBUILD b/PKGBUILD
index d7b27a1fc42e..3ef8324128c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,9 +7,6 @@
# - http://forums.fedoraforum.org/showthread.php?p=1678303#post1678303
_attempt_fix=0
-# Build an unstable 64-bit build: "1" to enable.
-_64=0
-
pkgname=google-earth
pkgver=7.1.7.2600
pkgrel=1
@@ -17,51 +14,36 @@ pkgdesc="A 3D interface to view satellite images of Earth and other objects"
arch=('i686' 'x86_64')
url="https://www.google.com/earth/index.html"
license=('custom:earth')
-# Bin32
-depends=('desktop-file-utils' 'hicolor-icon-theme' 'ld-lsb>=3-5' 'lib32-fontconfig' 'lib32-glu'
- 'lib32-libgl' 'lib32-libsm' 'lib32-libxrender' 'lib32-mesa' 'shared-mime-info' 'xdg-utils')
-[[ $_attempt_fix = 1 ]] && depends+=('gcc-multilib' 'lib32-freeimage' 'lib32-libpng15' 'lib32-qt4')
-optdepends=('lib32-catalyst-utils: For AMD Catalyst'
- 'lib32-nvidia-utils: For the NVIDIA driver')
-# Native 32/64-bit
-_arch=i386
-[[ $CARCH = x86_64 ]] && [[ $_64 = 1 ]] && _arch=amd64
-if [[ $CARCH = i686 ]] || [[ $_arch = amd64 ]]; then
- depends=('desktop-file-utils' 'fontconfig' 'glu' 'hicolor-icon-theme' 'ld-lsb>=3-5'
- 'libgl' 'libsm' 'libxrender' 'mesa' 'shared-mime-info' 'xdg-utils')
- [[ $_attempt_fix = 1 ]] && depends+=('freeimage' 'libpng15' 'qtwebkit')
- optdepends=('catalyst-utils: For AMD Catalyst'
- 'nvidia-utils: For the NVIDIA driver')
-fi
+depends=('desktop-file-utils' 'fontconfig' 'glu' 'hicolor-icon-theme' 'ld-lsb>=3-5'
+ 'libgl' 'libsm' 'libxrender' 'mesa' 'shared-mime-info' 'xdg-utils')
+[[ $_attempt_fix = 1 ]] && depends+=('freeimage' 'libpng15' 'qtwebkit')
+optdepends=('catalyst-utils: For AMD Catalyst'
+ 'nvidia-utils: For the NVIDIA driver')
options=('!emptydirs')
install=$pkgname.install
-source=("google-earth-stable_${pkgver}_${_arch}.deb::https://dl.google.com/earth/client/current/google-earth-stable_current_${_arch}.deb"
- 'googleearth.sh'
+source=('googleearth.sh'
'baifaao.cpp'
'Google-Terms-of-Service.html::https://www.google.com/intl/ALL/policies/terms/index.html'
'Google-Earth-Additional-Terms-of-Service.html::https://www.google.com/help/terms_maps.html'
'Legal-Notices-for-Google-Earth-and-Google-Earth-APIs.html::https://www.google.com/help/legalnotices_maps.html'
'Google-Privacy-Policy.html::https://www.google.com/intl/ALL/policies/privacy/index.html')
-md5sums=('cc02daa74d1b81daf44326a25460a88b'
- 'e84f5d51ea3545c131d1794f89f6464a'
+source_i686=("google-earth-stable_${pkgver}_i386.deb::https://dl.google.com/earth/client/current/google-earth-stable_current_i386.deb")
+source_x86_64=("google-earth-stable_${pkgver}_amd64.deb::https://dl.google.com/earth/client/current/google-earth-stable_current_amd64.deb")
+md5sums=('e84f5d51ea3545c131d1794f89f6464a'
'598d579a1c3199c77850d86ba78f7b44'
'SKIP'
'SKIP'
'SKIP'
'SKIP')
-[[ $_arch = amd64 ]] && md5sums[0]='e6356f9bb99d9019ee0a156f9331beb8'
+md5sums_i686=('cc02daa74d1b81daf44326a25460a88b')
+md5sums_x86_64=('e6356f9bb99d9019ee0a156f9331beb8')
_instdir=/opt/google/earth/free/
# Build the baifaao.so
if [[ $_attempt_fix = 1 ]]; then
build() {
- # bin32?
- if [[ $CARCH = x86_64 ]] && [[ $_64 != 1 ]]; then
- _m32=-m32
- fi
-
- gcc -I /usr/include/qt4/ $_m32 -O3 -fPIC --shared baifaao.cpp -o baifaao.so
+ gcc -I /usr/include/qt4/ -O3 -fPIC --shared baifaao.cpp -o baifaao.so
}
fi
@@ -100,11 +82,6 @@ package() {
# Preload it
install -m755 googleearth.sh "$pkgdir"/$_instdir/googleearth
- # bin32?
- if [[ "$_m32" ]]; then
- sed -i "s,/usr/lib,/usr/lib32,g" "$pkgdir"/$_instdir/googleearth
- fi
-
# Remove the old, bundled Qt libs
rm "$pkgdir"/$_instdir/libQt*
fi