summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDet2015-07-12 23:40:41 +0300
committerDet2015-07-12 23:40:41 +0300
commit2de03c9a2d25b8f56d2b772badbe88fb06c47594 (patch)
tree356e3ffeadb972f23eaa80b30b1ecf6cf4dcc715
parent4f05b83ba39005277501d2db192522e6582b0bda (diff)
downloadaur-2de03c9a2d25b8f56d2b772badbe88fb06c47594.tar.gz
Remove useless MIME package + clean up .install
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--google-earth-mimetypes.xml20
-rw-r--r--google-earth.install7
4 files changed, 4 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43ff9cb408f1..2a14ece36dbe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -24,14 +24,10 @@ pkgbase = google-earth
options = !emptydirs
source = google-earth-stable_7.1.4.1529_i386.deb::https://dl.google.com/earth/client/current/google-earth-stable_current_i386.deb
source = googleearth
- source = google-earth-mimetypes.xml
source = baifaao.cpp
md5sums = b8847cb867bdb3ff892149f0fd68f036
md5sums = e84f5d51ea3545c131d1794f89f6464a
- md5sums = e3c67b8d05c3de50535bd7e45eee728e
md5sums = 598d579a1c3199c77850d86ba78f7b44
- source_x86_64_unstable = google-earth-stable_7.1.4.1529_amd64.deb::https://dl.google.com/earth/client/current/google-earth-stable_current_amd64.deb
- md5sums_x86_64_unstable = 7bbba9d4d64f2a9b38752e259d849bda
pkgname = google-earth
diff --git a/PKGBUILD b/PKGBUILD
index 05f976139040..4fcaaa48f753 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -38,11 +38,9 @@ options=('!emptydirs')
install=$pkgname.install
source=("google-earth-stable_${pkgver}_${_arch}.deb::https://dl.google.com/earth/client/current/google-earth-stable_current_${_arch}.deb"
'googleearth'
- 'google-earth-mimetypes.xml'
'baifaao.cpp')
md5sums=('b8847cb867bdb3ff892149f0fd68f036'
'e84f5d51ea3545c131d1794f89f6464a'
- 'e3c67b8d05c3de50535bd7e45eee728e'
'598d579a1c3199c77850d86ba78f7b44')
[[ $_arch = amd64 ]] && md5sums[0]='7bbba9d4d64f2a9b38752e259d849bda'
@@ -73,9 +71,6 @@ package() {
install -Dm644 "$pkgdir"/$_instdir/product_logo_$i.png "$pkgdir"/usr/share/icons/hicolor/${i}x${i}/apps/google-earth.png
done
- # The MIME package
- install -Dm644 google-earth-mimetypes.xml "$pkgdir"/usr/share/mime/packages/google-earth-mimetypes.xml
-
# The license (too many different ones to do this in "source=()")
install -d "$pkgdir"/usr/share/licenses/google-earth/
curl -Ls ${url/i*}/license.html -o "$pkgdir"/usr/share/licenses/google-earth/license.html
diff --git a/google-earth-mimetypes.xml b/google-earth-mimetypes.xml
deleted file mode 100644
index 5bb218b4c87a..000000000000
--- a/google-earth-mimetypes.xml
+++ /dev/null
@@ -1,20 +0,0 @@
-<?xml version="1.0"?>
-<mime-info xmlns='http://www.freedesktop.org/standards/shared-mime-info'>
- <mime-type type="application/vnd.google-earth.kml+xml">
- <comment>Keyhole Markup Language data</comment>
- <glob pattern="*.kml"/>
- </mime-type>
-
- <mime-type type="application/vnd.google-earth.kmz">
- <comment>Keyhole Markup Language archive</comment>
- <glob pattern="*.kmz"/>
- </mime-type>
-
- <mime-type type="application/keyhole">
- <comment>Keyhole Markup Language data</comment>
- </mime-type>
-
- <mime-type type="application/earthviewer">
- <comment>Keyhole Markup Language data</comment>
- </mime-type>
-</mime-info> \ No newline at end of file
diff --git a/google-earth.install b/google-earth.install
index 58a172690470..d11379add451 100644
--- a/google-earth.install
+++ b/google-earth.install
@@ -20,16 +20,16 @@ fi
_update() {
msg_blue "Updating desktop MIME database..."
update-desktop-database -q
- msg_blue "Updating MIME database..."
- update-mime-database usr/share/mime >/dev/null
+
msg_blue "Updating icon cache..."
xdg-icon-resource forceupdate &>/dev/null
}
post_install() {
_update
+
if [[ $_64 ]]; then
- note "The binary is called 'google-earth'." "1"
+ note "The launcher is called 'google-earth'." "1"
note "If experiencing graphical corruption:
$ rm -r ~/.googleearth/Cache/" "2"
else
@@ -39,6 +39,7 @@ post_install() {
post_upgrade() {
_update
+
if [[ $_64 ]]; then
note "If experiencing graphical corruption:
$ rm -r ~/.googleearth/Cache/"