summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDet2016-02-21 20:44:22 +0200
committerDet2016-02-21 20:44:22 +0200
commitb850db9f3470b8b327fb1d223fb1fb58c9f0ac9e (patch)
treea46db2c2fcc9663c48abe6f8da7e1ffd770b2f28
parent2142c72a58ee1dd93b26ded2e704f2e7f51f7e13 (diff)
downloadaur-b850db9f3470b8b327fb1d223fb1fb58c9f0ac9e.tar.gz
We could also use our head instead
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD34
2 files changed, 30 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 23d7cda5e99f..369c9570c1ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Feb 21 18:26:00 UTC 2016
+# Sun Feb 21 18:44:22 UTC 2016
pkgbase = google-earth
pkgdesc = A 3D interface to view satellite images of Earth and other objects
pkgver = 7.1.4.1529
@@ -27,9 +27,17 @@ pkgbase = google-earth
source = google-earth-stable_7.1.4.1529_i386.deb::https://dl.google.com/earth/client/current/google-earth-stable_current_i386.deb
source = googleearth
source = baifaao.cpp
+ source = Google-Terms-of-Service.html::https://www.google.com/intl/ALL/policies/terms/index.html
+ source = Google-Earth-Additional-Terms-of-Service.html::https://www.google.com/help/terms_maps.html
+ source = Legal-Notices-for-Google-Earth-and-Google-Earth-APIs.html::https://www.google.com/help/legalnotices_maps.html
+ source = Google-Privacy-Policy.html::https://www.google.com/intl/ALL/policies/privacy/index.html
md5sums = b8847cb867bdb3ff892149f0fd68f036
md5sums = e84f5d51ea3545c131d1794f89f6464a
md5sums = 598d579a1c3199c77850d86ba78f7b44
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
pkgname = google-earth
diff --git a/PKGBUILD b/PKGBUILD
index 11790514ec65..fe1f829b8570 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -38,10 +38,18 @@ options=('!emptydirs')
install=$pkgname.install
source=("google-earth-stable_${pkgver}_${_arch}.deb::https://dl.google.com/earth/client/current/google-earth-stable_current_${_arch}.deb"
'googleearth'
- 'baifaao.cpp')
+ 'baifaao.cpp'
+ 'Google-Terms-of-Service.html::https://www.google.com/intl/ALL/policies/terms/index.html'
+ 'Google-Earth-Additional-Terms-of-Service.html::https://www.google.com/help/terms_maps.html'
+ 'Legal-Notices-for-Google-Earth-and-Google-Earth-APIs.html::https://www.google.com/help/legalnotices_maps.html'
+ 'Google-Privacy-Policy.html::https://www.google.com/intl/ALL/policies/privacy/index.html')
md5sums=('b8847cb867bdb3ff892149f0fd68f036'
'e84f5d51ea3545c131d1794f89f6464a'
- '598d579a1c3199c77850d86ba78f7b44')
+ '598d579a1c3199c77850d86ba78f7b44'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
[[ $_arch = amd64 ]] && md5sums[0]='7bbba9d4d64f2a9b38752e259d849bda'
_instdir=/opt/google/earth/free/
@@ -68,19 +76,19 @@ package() {
# Icons
for i in 16 22 24 32 48 64 128 256; do
- install -Dm644 "$pkgdir"/$_instdir/product_logo_$i.png "$pkgdir"/usr/share/icons/hicolor/${i}x${i}/apps/google-earth.png
+ install -Dm644 "$pkgdir"/$_instdir/product_logo_$i.png \
+ "$pkgdir"/usr/share/icons/hicolor/${i}x${i}/apps/google-earth.png
done
- # Licenses (different countries redirect to different ones)
- install -d "$pkgdir"/usr/share/licenses/$pkgname/
- curl -Ls https://www.google.com/intl/ALL/policies/terms/index.html \
- -o "$pkgdir/usr/share/licenses/$pkgname/Google Terms of Service.html"
- curl -Ls https://www.google.com/help/terms_maps.html \
- -o "$pkgdir/usr/share/licenses/$pkgname/Google Earth Additional Terms of Service.html"
- curl -Ls https://www.google.com/help/legalnotices_maps.html \
- -o "$pkgdir/usr/share/licenses/$pkgname/Legal Notices for Google Earth and Google Earth APIs.html"
- curl -Ls https://www.google.com/intl/ALL/policies/privacy/index.html \
- -o "$pkgdir/usr/share/licenses/$pkgname/Google Privacy Policy.html"
+ # Licenses
+ install -Dm644 'Google-Terms-of-Service.html' \
+ "$pkgdir/usr/share/licenses/$pkgname/Google-Terms-of-Service.html"
+ install -Dm644 'Google-Earth-Additional-Terms-of-Service.html' \
+ "$pkgdir/usr/share/licenses/$pkgname/Google-Earth-Additional-Terms-of-Service.html"
+ install -Dm644 'Legal-Notices-for-Google-Earth-and-Google-Earth-APIs.html' \
+ "$pkgdir/usr/share/licenses/$pkgname/Legal-Notices-for-Google-Earth-and-Google-Earth-APIs.html"
+ install -Dm644 'Google-Privacy-Policy.html' \
+ "$pkgdir/usr/share/licenses/$pkgname/Google-Privacy-Policy.html"
msg2 "Removing the Debian-intended cron job and duplicated images..."
rm -r "$pkgdir"/etc/cron.daily/ "$pkgdir"/$_instdir/product_logo_*.png