summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDet2016-09-01 06:08:17 +0300
committerDet2016-09-01 06:08:17 +0300
commiteb330ed7f7acb1ed43ee7cddc7c810e6ca136d76 (patch)
tree25f4dfbd176e63a616114e74baa56f00d47971b0
parentde949fcd70f2329f14f48b7559001e44dda05e9b (diff)
downloadaur-eb330ed7f7acb1ed43ee7cddc7c810e6ca136d76.tar.gz
Fixed build
-rw-r--r--PKGBUILD4
-rw-r--r--google-earth.install20
2 files changed, 4 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 11dc479e9c7e..d7b27a1fc42e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -66,8 +66,8 @@ if [[ $_attempt_fix = 1 ]]; then
fi
package() {
- msg2 "Extracting the data.tar.lzma..."
- bsdtar -xf data.tar.lzma -C "$pkgdir/"
+ msg2 "Extracting the data.tar.xz..."
+ bsdtar -xf data.tar.xz -C "$pkgdir/"
msg2 "Moving stuff in place..."
# The .desktop
diff --git a/google-earth.install b/google-earth.install
index d11379add451..1d5707333956 100644
--- a/google-earth.install
+++ b/google-earth.install
@@ -17,17 +17,7 @@ if [[ $(uname -m) = x86_64 ]]; then
_64=true
fi
-_update() {
- msg_blue "Updating desktop MIME database..."
- update-desktop-database -q
-
- msg_blue "Updating icon cache..."
- xdg-icon-resource forceupdate &>/dev/null
-}
-
-post_install() {
- _update
-
+post_install() {
if [[ $_64 ]]; then
note "The launcher is called 'google-earth'." "1"
note "If experiencing graphical corruption:
@@ -37,15 +27,9 @@ post_install() {
fi
}
-post_upgrade() {
- _update
-
+post_upgrade() {
if [[ $_64 ]]; then
note "If experiencing graphical corruption:
$ rm -r ~/.googleearth/Cache/"
fi
}
-
-post_remove() {
- _update
-}