summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDet2015-06-14 04:13:27 +0300
committerDet2015-06-14 04:14:15 +0300
commit43feef94cd7f7bfa72bff0ccdca8a1930080108c (patch)
treeb60148251ef1d2aa44e0d3ced157accf757a60ff
downloadaur-43feef94cd7f7bfa72bff0ccdca8a1930080108c.tar.gz
Initial import: 6.2.2.6613-2
-rw-r--r--.SRCINFO51
-rw-r--r--PKGBUILD85
-rw-r--r--google-earth6-mimetypes.xml20
-rw-r--r--google-earth6.desktop12
-rw-r--r--google-earth6.install37
-rw-r--r--google-earth6.menu6
-rw-r--r--googleearth12
7 files changed, 223 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a983b66691b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,51 @@
+pkgbase = google-earth6
+ pkgdesc = A legacy 3D interface to view satellite images of Earth and other objects
+ pkgver = 6.2.2.6613
+ pkgrel = 2
+ url = http://www.google.com/earth
+ install = google-earth6.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = pacman>=4.2.0
+ depends = desktop-file-utils
+ depends = hicolor-icon-theme
+ depends = ld-lsb
+ depends = shared-mime-info
+ depends = xdg-utils
+ optdepends = qt4: For changing the font size with qtconfig
+ optdepends = ttf-ms-fonts: Fonts
+ options = !emptydirs
+ source = googleearth
+ source = google-earth6.desktop
+ source = google-earth6.menu
+ source = google-earth6-mimetypes.xml
+ md5sums = e5f591e3bd44743539722e019611b773
+ md5sums = bfacc99dae6bc5ded73cd9b3bd2c9087
+ md5sums = 3e87399f2051321102a59227e6d6ded7
+ md5sums = e3c67b8d05c3de50535bd7e45eee728e
+ source_i686 = http://packages.linuxmint.com/pool/import/g/googleearth/googleearth_6.2.2.6613-r0_i386.deb
+ depends_i686 = fontconfig
+ depends_i686 = glu
+ depends_i686 = libgl
+ depends_i686 = libsm
+ depends_i686 = libxrender
+ depends_i686 = mesa
+ optdepends_i686 = catalyst-utils: For AMD Catalyst
+ optdepends_i686 = nvidia-utils: For the NVIDIA driver
+ md5sums_i686 = e38c0d806cf1d581213fb6f4f204ec9c
+ source_x86_64 = http://packages.linuxmint.com/pool/import/g/googleearth/googleearth_6.2.2.6613-r0_amd64.deb
+ depends_x86_64 = lib32-curl
+ depends_x86_64 = lib32-fontconfig
+ depends_x86_64 = lib32-gcc-libs
+ depends_x86_64 = lib32-glu
+ depends_x86_64 = lib32-libgl
+ depends_x86_64 = lib32-libsm
+ depends_x86_64 = lib32-libxrender
+ depends_x86_64 = lib32-mesa
+ optdepends_x86_64 = lib32-catalyst-utils: For AMD Catalyst
+ optdepends_x86_64 = lib32-nvidia-utils: For the NVIDIA driver
+ md5sums_x86_64 = bd1960eb3e2d061b319c3f38835840d7
+
+pkgname = google-earth6
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ada143683963
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,85 @@
+# Maintainer: Det <nimetonmaili g-mail>
+# Based on google-earth: https://aur.archlinux.org/packages/google-earth/
+
+pkgname=google-earth6
+pkgver=6.2.2.6613
+pkgrel=2
+pkgdesc="A legacy 3D interface to view satellite images of Earth and other objects"
+arch=('i686' 'x86_64')
+url="http://www.google.com/earth"
+license=('custom')
+depends=('desktop-file-utils' 'hicolor-icon-theme' 'ld-lsb' 'shared-mime-info' 'xdg-utils')
+depends_i686=('fontconfig' 'glu' 'libgl' 'libsm' 'libxrender' 'mesa')
+depends_x86_64=('lib32-curl' 'lib32-fontconfig' 'lib32-gcc-libs' 'lib32-glu'
+ 'lib32-libgl' 'lib32-libsm' 'lib32-libxrender' 'lib32-mesa')
+optdepends=('qt4: For changing the font size with qtconfig'
+ 'ttf-ms-fonts: Fonts')
+optdepends_i686=('catalyst-utils: For AMD Catalyst'
+ 'nvidia-utils: For the NVIDIA driver')
+optdepends_x86_64=('lib32-catalyst-utils: For AMD Catalyst'
+ 'lib32-nvidia-utils: For the NVIDIA driver')
+makedepends=('pacman>=4.2.0')
+options=('!emptydirs')
+install=$pkgname.install
+source=('googleearth'
+ "$pkgname.desktop"
+ "$pkgname.menu"
+ "$pkgname-mimetypes.xml")
+source_i686=("http://packages.linuxmint.com/pool/import/g/googleearth/googleearth_$pkgver-r0_i386.deb")
+source_x86_64=("http://packages.linuxmint.com/pool/import/g/googleearth/googleearth_$pkgver-r0_amd64.deb")
+md5sums=('e5f591e3bd44743539722e019611b773' # googleearth
+ 'bfacc99dae6bc5ded73cd9b3bd2c9087' # google-earth6.desktop
+ '3e87399f2051321102a59227e6d6ded7' # google-earth6.menu
+ 'e3c67b8d05c3de50535bd7e45eee728e') # google-earth6-mimetypes.xml
+md5sums_i686=('e38c0d806cf1d581213fb6f4f204ec9c')
+md5sums_x86_64=('bd1960eb3e2d061b319c3f38835840d7')
+
+_instdir=/opt/google/earth/legacy
+
+package() {
+ msg2 "Extracting the data.tar.gz..."
+ bsdtar -xf data.tar.gz -C "$pkgdir/"
+
+ msg2 "Making us coexist with 'google-earth'..."
+ # Installation directory
+ mv "$pkgdir"/opt/google/earth/free/ "$pkgdir"/$_instdir/
+
+ # Symlinks
+ rm "$pkgdir"/usr/bin/${pkgname/6}
+ ln -sf $_instdir/googleearth "$pkgdir"/usr/bin/$pkgname
+ ln -sf $_instdir/googleearth "$pkgdir"/$_instdir/${pkgname/6}
+
+ # Menu
+ rm "$pkgdir"/usr/share/menu/google-earth.menu
+
+ msg2 "Moving stuff in place..."
+ # Main script
+ install -m755 googleearth "$pkgdir"/$_instdir/
+
+ # Desktop
+ install -m644 $pkgname.desktop "$pkgdir"/usr/share/applications/
+
+ # Icons
+ for i in 16 22 24 32 48 64 128 256; do
+ install -Dm644 "$pkgdir"/$_instdir/product_logo_$i.png "$pkgdir"/usr/share/icons/hicolor/${i}x${i}/apps/$pkgname.png
+ done
+
+ # Menu
+ install -Dm644 $pkgname.menu "$pkgdir"/usr/share/menu/$pkgname.menu
+
+ # MIME package
+ install -Dm644 $pkgname-mimetypes.xml "$pkgdir"/usr/share/mime/packages/$pkgname-mimetypes.xml
+
+ # License
+ install -d "$pkgdir"/usr/share/licenses/$pkgname/
+ curl -Ls $url/license.html -o "$pkgdir"/usr/share/licenses/$pkgname/license.html
+
+ msg2 "Removing the duplicated images and .desktop..."
+ rm "$pkgdir"/$_instdir/product_logo_*.png "$pkgdir"/$_instdir/${pkgname/6}.desktop
+
+ msg2 "Fixing searches..."
+ rm "$pkgdir"/$_instdir/libcurl.so.4
+
+ msg2 "Fixing permissions..."
+ chown 0:0 -R "$pkgdir"/
+}
diff --git a/google-earth6-mimetypes.xml b/google-earth6-mimetypes.xml
new file mode 100644
index 000000000000..5bb218b4c87a
--- /dev/null
+++ b/google-earth6-mimetypes.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0"?>
+<mime-info xmlns='http://www.freedesktop.org/standards/shared-mime-info'>
+ <mime-type type="application/vnd.google-earth.kml+xml">
+ <comment>Keyhole Markup Language data</comment>
+ <glob pattern="*.kml"/>
+ </mime-type>
+
+ <mime-type type="application/vnd.google-earth.kmz">
+ <comment>Keyhole Markup Language archive</comment>
+ <glob pattern="*.kmz"/>
+ </mime-type>
+
+ <mime-type type="application/keyhole">
+ <comment>Keyhole Markup Language data</comment>
+ </mime-type>
+
+ <mime-type type="application/earthviewer">
+ <comment>Keyhole Markup Language data</comment>
+ </mime-type>
+</mime-info> \ No newline at end of file
diff --git a/google-earth6.desktop b/google-earth6.desktop
new file mode 100644
index 000000000000..f96e46730a55
--- /dev/null
+++ b/google-earth6.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Version=1.0
+Name=Google Earth Legacy
+GenericName=Legacy 3D planet viewer
+Comment=Explore, search and discover the planet
+Exec=/opt/google/earth/legacy/google-earth %f
+Terminal=false
+MultipleArgs=false
+Icon=google-earth6
+Type=Application
+Categories=Application;Network
+MimeType=application/vnd.google-earth.kml+xml;application/vnd.google-earth.kmz;application/earthviewer;application/keyhole
diff --git a/google-earth6.install b/google-earth6.install
new file mode 100644
index 000000000000..0755338df5dd
--- /dev/null
+++ b/google-earth6.install
@@ -0,0 +1,37 @@
+# Colored makepkg-like functions
+msg_blue() {
+ printf "${blue}==>${bold} $1${all_off}\n"
+}
+
+note() {
+ printf "${blue}==>${yellow} NOTE:$1${bold} $2${all_off}\n"
+}
+
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+_update() {
+ msg_blue "Updating desktop MIME database..."
+ update-desktop-database -q
+ msg_blue "Updating MIME database..."
+ update-mime-database usr/share/mime >/dev/null
+ msg_blue "Updating icon cache..."
+ xdg-icon-resource forceupdate &>/dev/null
+}
+
+post_install() {
+ _update
+ note 1 "The launcher is called 'google-earth6'."
+ note 2 "This package installs side-by-side with 'google-earth' (v7)."
+ note 3 "Keep in mind both versions sharing ~/.googleearth/ might not work as inteded."
+}
+
+post_upgrade() {
+ _update
+}
+
+post_remove() {
+ _update
+} \ No newline at end of file
diff --git a/google-earth6.menu b/google-earth6.menu
new file mode 100644
index 000000000000..1d0567554a06
--- /dev/null
+++ b/google-earth6.menu
@@ -0,0 +1,6 @@
+?package(google-earth):needs="x11" \
+ section="Applications/Network/Web Browsing" \
+ hints="Web browsers" \
+ title="Google Earth (Legacy)" \
+ icon="/opt/google/earth/legacy/product_logo_32.xpm" \
+ command="/opt/google/earth/legacy/google-earth"
diff --git a/googleearth b/googleearth
new file mode 100644
index 000000000000..558a66d3708e
--- /dev/null
+++ b/googleearth
@@ -0,0 +1,12 @@
+#!/bin/sh
+# Always run Google Earth from this shell script and not directly!
+# This script makes sure the app looks in the right place for libraries
+# that might also reside elsewhere.
+#
+# Ryan C. Gordon, Thu Jul 20 14:32:33 PDT 2006
+
+# We alredy know the path
+cd /opt/google/earth/legacy
+
+# Launch the app
+LD_LIBRARY_PATH=.:$LD_LIBRARY_PATH ./googleearth-bin "$@"