summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2019-01-14 13:18:34 -0500
committerGuillaume Horel2019-01-14 13:18:34 -0500
commit06cf2863288930e43d9f0d60eafc7d8df34c0525 (patch)
tree057b5f875abe123db94b104b46ff04033f4d83a1
parent298b58ec45bd3944536627261b1c4f3864877d6b (diff)
downloadaur-06cf2863288930e43d9f0d60eafc7d8df34c0525.tar.gz
switch to cmake build
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ff49c6f9180..0bc7cfa67130 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,7 +10,7 @@ pkgbase = google-glog-static
conflicts = google-glog
options = staticlibs
source = glog-0.3.5.tar.gz::https://github.com/google/glog/archive/v0.3.5.tar.gz
- sha512sums = a54a3b8b4b7660d7558ba5168c659bc3c8323c30908a4f6a4bbc6f9cd899350f3243aabc720daebfdeb799b276b51ba1eaa1a0f83149c4e1a038d552ada1ed72
+ sha256sums = 7580e408a2c0b5a89ca214739978ce6ff480b5e7d8d7698a2aa92fadc484d1e0
pkgname = google-glog-static
diff --git a/PKGBUILD b/PKGBUILD
index a0e006ad7be0..bc368b95a6a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,22 +13,23 @@ options=('staticlibs')
source=("glog-$pkgver.tar.gz::https://github.com/google/glog/archive/v$pkgver.tar.gz")
provides=('google-glog')
conflicts=('google-glog')
-sha512sums=('a54a3b8b4b7660d7558ba5168c659bc3c8323c30908a4f6a4bbc6f9cd899350f3243aabc720daebfdeb799b276b51ba1eaa1a0f83149c4e1a038d552ada1ed72')
+sha256sums=('7580e408a2c0b5a89ca214739978ce6ff480b5e7d8d7698a2aa92fadc484d1e0')
build() {
cd glog-$pkgver
-
- ./configure --prefix=/usr
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
make
}
package() {
- cd glog-$pkgver
+ cd glog-$pkgver/build
make DESTDIR="$pkgdir" install
# Lazy way of dealing with conflicting man and info pages...
rm -rf "$pkgdir"/usr/share
- install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+ install -Dm644 ../COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}