summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortoluschr2019-04-17 13:17:29 +0200
committertoluschr2019-04-17 13:17:29 +0200
commit4b243ee7b239fc2339d7f7277ce57ae5e6f51571 (patch)
tree46cd54d8c32125f0da5442447f2b8325130200ff
parente20c8d88378fdee12f0f25f19bd959605bc1fa76 (diff)
downloadaur-4b243ee7b239fc2339d7f7277ce57ae5e6f51571.tar.gz
fixed: many issues in PKGBUILD
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD24
2 files changed, 13 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 283b17d51f4c..51fea9f8d6f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = google-keep-nativefier
pkgdesc = Quickly capture what's on your mind and get a reminder later at the right place or time. Speak a voice memo on the go and have it automatically transcribed.
- pkgver = 0.1
- pkgrel = 3
+ pkgver = 0.2
+ pkgrel = 1
url = https://keep.google.com/
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 2ca9cdfe6601..0eb7e7af8293 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname="google-keep-nativefier"
-pkgver="0.1"
-pkgrel="3"
+pkgver="0.2"
+pkgrel="1"
pkgdesc="Quickly capture what's on your mind and get a reminder later at the right place or time. Speak a voice memo on the go and have it automatically transcribed."
arch=("x86_64")
license=("MIT")
@@ -22,19 +22,17 @@ build() {
}
package() {
- cd $pkgdir
+ install -dm644 "$pkgdir/opt/"
+ install -dm644 "$pkgdir/usr/bin"
+ install -dm644 "$pkgdir/usr/share/pixmaps"
+ install -dm644 "$pkgdir/usr/share/applications"
- install -dm755 "opt/"
- install -dm755 "usr/bin"
- install -dm755 "usr/share/pixmaps"
- install -dm755 "usr/share/applications"
+ install -m644 "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/$instname.desktop"
+ cp -rL "$srcdir/$instname-linux-"* "$pkgdir/opt/$pkgname"
- install -m644 "$srcdir/$pkgname.desktop" "usr/share/applications/${instname}.desktop"
- install -m644 "$srcdir/$instname-linux-x64" "opt/"
+ ln -sf "/opt/$pkgname/$instname" "$pkgdir/usr/bin/$instname"
+ ln -sf "/opt/$pkgname/resources/app/icon.png" "$pkgdir/usr/share/pixmaps/$instname.png"
- ln -sf "/opt/${instname}-linux-x64/${instname}" "usr/bin/${instname}"
- ln -sf "/opt/${instname}-linux-x64/resources/app/icon.png" "usr/share/pixmaps/${instname}.png"
-
- chmod 777 "opt/${instname}-linux-x64/resources/app/nativefier.json"
+ chmod 777 "$pkgdir/opt/$pkgname/resources/app/nativefier.json"
}