summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302020-01-23 21:57:43 +0100
committerM0Rf302020-01-23 21:57:43 +0100
commit85f5ba278de68cae752b5213568c133418f9c923 (patch)
tree92aff09a039e149cfe38aae7b1680d6719a40411
downloadaur-85f5ba278de68cae752b5213568c133418f9c923.tar.gz
google-music-manager-auth: 1.3.0
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9d59d4f0845b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = google-music-manager-auth
+ pkgdesc = Google Music Manager Auth Daemon
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = https://github.com/jaymoulin/google-music-manager-auth
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-beautifulsoup4
+ depends = python-gmusicapi
+ depends = python-netifaces
+ depends = python-watchdog
+ source = https://github.com/jaymoulin/google-music-manager-auth/archive/1.3.0.tar.gz
+ sha256sums = cced52b6b3c927daf94ed97ddecab29ad252e9fac3edb4d2400a4e979cda207e
+
+pkgname = google-music-manager-auth
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f5bc005bec0b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: robertfoster
+pkgname=google-music-manager-auth
+pkgver=1.3.0
+pkgrel=1
+pkgdesc="Google Music Manager Auth Daemon"
+arch=('any')
+url="https://github.com/jaymoulin/google-music-manager-auth"
+license=('MIT')
+depends=('python-beautifulsoup4' 'python-gmusicapi' 'python-netifaces' 'python-watchdog' )
+makedepends=('python-setuptools')
+source=("https://github.com/jaymoulin/google-music-manager-auth/archive/$pkgver.tar.gz")
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ sed -i 's/bs4/beautifulsoup4/g' setup.cfg
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+
+sha256sums=('cced52b6b3c927daf94ed97ddecab29ad252e9fac3edb4d2400a4e979cda207e')