summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimone Scalabrino2018-03-26 19:00:04 +0200
committerSimone Scalabrino2018-03-26 19:00:04 +0200
commitf8a93498b185dcdb88fe74f9838f7cc7b71a603f (patch)
tree8fb2a89e65deef702736534c0fc015679dd72043
downloadaur-f8a93498b185dcdb88fe74f9838f7cc7b71a603f.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
-rw-r--r--google-photos.desktop13
-rw-r--r--google-photos.qtws29
-rw-r--r--google-photos.svg13
5 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f95ad760f8a5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = google-photos-desktop
+ pkgdesc = Google Photos web-app based on qtws
+ pkgver = 0.9
+ pkgrel = 1
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = qtws-base
+ source = google-photos.qtws
+ source = google-photos.svg
+ source = google-photos.desktop
+ md5sums = d1fb07538cc1d3485263bbaa3d122206
+ md5sums = da3df6c6eaaba6ee9b2f3f0b3973efcb
+ md5sums = 1b24fc333aaebd55476f5012aed246be
+
+pkgname = google-photos-desktop
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..efb58cd5af3e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Simone Scalabrino <s dot scalabrino 9 at gmail dot com>
+webappname=google-photos
+pkgname=${webappname}-desktop
+pkgver=0.9
+pkgrel=1
+pkgdesc='Google Photos web-app based on qtws'
+arch=('i686' 'x86_64')
+license=('GPL3')
+depends=('qtws-base')
+source=("$webappname.qtws" "$webappname.svg" "$webappname.desktop")
+md5sums=('d1fb07538cc1d3485263bbaa3d122206'
+ 'da3df6c6eaaba6ee9b2f3f0b3973efcb'
+ '1b24fc333aaebd55476f5012aed246be')
+
+package() {
+ mkdir -p ${pkgdir}/usr/share/qtws-apps/$webappname
+ echo ${srcdir}
+
+ install -Dm644 "${srcdir}/$webappname.qtws" "${pkgdir}/usr/share/qtws-apps/$webappname/$webappname.qtws"
+ install -Dm755 "${srcdir}/$webappname.desktop" "${pkgdir}/usr/share/applications/$webappname-desktop.desktop"
+ install -Dm644 "${srcdir}/$webappname.svg" "${pkgdir}/usr/share/pixmaps/$webappname-desktop.svg"
+}
+
diff --git a/google-photos.desktop b/google-photos.desktop
new file mode 100644
index 000000000000..17a0fd3c2707
--- /dev/null
+++ b/google-photos.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Categories=Multimedia;
+Comment=Google Photos Standalone
+Exec=/usr/bin/qtws /usr/share/qtws-apps/google-photos/google-photos.qtws --disable-seccomp-filter-sandbox --register-pepper-plugins="/usr/lib/qt/plugins/ppapi/libwidevinecdmadapter.so; application/x-ppapi-widevine-cdm"
+GenericName=Google Photos
+Icon=google-photos-desktop.svg
+MimeType=
+Name=Google Photos
+Path=
+StartupNotify=true
+Terminal=false
+TerminalOptions=
+Type=Application
diff --git a/google-photos.qtws b/google-photos.qtws
new file mode 100644
index 000000000000..fffe8bfa090e
--- /dev/null
+++ b/google-photos.qtws
@@ -0,0 +1,29 @@
+{
+ "name": "Google Photos",
+ "scope": ["google.com"],
+ "plugins": [],
+ "home": "https://photos.google.com/",
+ "icon": "/usr/share/pixmaps/google-photos-desktop.svg",
+ "saveSession": false,
+ "menu": [
+ {
+ "title": "Albums",
+ "action": "https://photos.google.com/albums"
+ },
+
+ {
+ "title": "Assistant",
+ "action": "https://photos.google.com/assistant"
+ },
+
+ {
+ "title": "Sharing",
+ "action": "https://photos.google.com/sharing"
+ },
+
+ {
+ "title": "Settings",
+ "action": "https://photos.google.com/settings"
+ }
+ ]
+}
diff --git a/google-photos.svg b/google-photos.svg
new file mode 100644
index 000000000000..5d34b32ad088
--- /dev/null
+++ b/google-photos.svg
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" viewBox="0 0 48 48" version="1.1" width="50px" height="50px">
+<g id="surface1">
+<path style=" fill:#F44336;" d="M 37 24 L 30.0625 24 C 26.714844 24 24 21.285156 24 17.9375 L 24 0.574219 C 24 0.355469 24.261719 0.238281 24.421875 0.390625 L 37 12 Z "/>
+<path style=" fill:#AD1457;" d="M 37 24 L 30.0625 24 C 28.628906 24 27.308594 23.5 26.269531 22.667969 L 37 12 Z "/>
+<path style=" fill:#8BC34A;" d="M 11 24 L 17.9375 24 C 21.285156 24 24 26.714844 24 30.0625 L 24 47.425781 C 24 47.644531 23.738281 47.757813 23.578125 47.609375 L 11 36 Z "/>
+<path style=" fill:#009688;" d="M 11 24 L 17.9375 24 C 19.371094 24 20.691406 24.5 21.730469 25.332031 L 11 36 Z "/>
+<path style=" fill:#FFC107;" d="M 24 11 L 24 17.9375 C 24 21.285156 21.285156 24 17.9375 24 L 0.574219 24 C 0.355469 24 0.238281 23.738281 0.390625 23.578125 L 12 11 Z "/>
+<path style=" fill:#FF9800;" d="M 24 11 L 24 17.9375 C 24 19.371094 23.5 20.691406 22.667969 21.730469 L 12 11 Z "/>
+<path style=" fill:#448AFF;" d="M 24 37 L 24 30.0625 C 24 26.714844 26.714844 24 30.0625 24 L 47.425781 24 C 47.644531 24 47.757813 24.261719 47.609375 24.421875 L 36 37 Z "/>
+<path style=" fill:#1565C0;" d="M 24 37 L 24 30.0625 C 24 28.628906 24.5 27.308594 25.332031 26.269531 L 36 37 Z "/>
+</g>
+</svg>